summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-01 18:27:58 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-01 18:28:10 +0200
commit30f3c1e392b6fa44984b9c94b4ca54418ea4b56f (patch)
treedd2e963a22ab9155f39a91be4e3c1fbce509d9c8 /dev-perl/Carp-Assert-More/Carp-Assert-More-1.260.0.ebuild
parentmedia-plugins/vdr-dvbsddevice: eapi 7 support (diff)
downloadgentoo-30f3c1e392b6fa44984b9c94b4ca54418ea4b56f.tar.gz
gentoo-30f3c1e392b6fa44984b9c94b4ca54418ea4b56f.tar.bz2
gentoo-30f3c1e392b6fa44984b9c94b4ca54418ea4b56f.zip
dev-perl/Carp-Assert-More: Version bump 1.26
Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Carp-Assert-More/Carp-Assert-More-1.260.0.ebuild')
-rw-r--r--dev-perl/Carp-Assert-More/Carp-Assert-More-1.260.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-perl/Carp-Assert-More/Carp-Assert-More-1.260.0.ebuild b/dev-perl/Carp-Assert-More/Carp-Assert-More-1.260.0.ebuild
new file mode 100644
index 000000000000..054413c07e65
--- /dev/null
+++ b/dev-perl/Carp-Assert-More/Carp-Assert-More-1.260.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PETDANCE
+DIST_VERSION=1.26
+inherit perl-module
+
+DESCRIPTION="convenience wrappers around Carp::Assert"
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ virtual/perl-Carp
+ dev-perl/Carp-Assert
+ virtual/perl-Scalar-List-Utils
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Exception
+ >=virtual/perl-Test-Simple-0.180.0
+ )
+"
+
+PERL_RM_FILES=(
+ "t/pod-coverage.t"
+ "t/pod.t"
+)
+
+src_test() {
+ perl-module_src_test
+ local MODULES=(
+ "Carp::Assert::More ${DIST_VERSION}"
+ )
+ for dep in "${MODULES[@]}"; do
+ perl -Mblib="${S}" -M"${dep} ()" -e1 ||
+ die "Could not load ${dep}"
+ done
+}