summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 23:28:07 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 23:28:29 +1200
commite0a51c2b7c41dd6602fc98c0a063722de9e71ee5 (patch)
treed0ff0e7817ab854a70d0659a4f765d3d33b5d75b /dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.90.0-r1.ebuild
parentprofiles: Mask games-board/teg for removal (diff)
downloadgentoo-e0a51c2b7c41dd6602fc98c0a063722de9e71ee5.tar.gz
gentoo-e0a51c2b7c41dd6602fc98c0a063722de9e71ee5.tar.bz2
gentoo-e0a51c2b7c41dd6602fc98c0a063722de9e71ee5.zip
dev-perl/Crypt-OpenSSL-Bignum: -r1 bump for EAPI7 + fixes
- EAPI7 - Ensure CFLAGS are passed to compile Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.90.0-r1.ebuild')
-rw-r--r--dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.90.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.90.0-r1.ebuild b/dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.90.0-r1.ebuild
new file mode 100644
index 000000000000..3609566d7c9e
--- /dev/null
+++ b/dev-perl/Crypt-OpenSSL-Bignum/Crypt-OpenSSL-Bignum-0.90.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=KMX
+DIST_VERSION=0.09
+inherit perl-module
+
+DESCRIPTION="OpenSSL's multiprecision integer arithmetic"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~ppc-aix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:0= )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/pkgconfig
+"
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}