summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-10-21 22:21:42 +1300
committerKent Fredric <kentnl@gentoo.org>2017-10-21 22:25:14 +1300
commit056e62af9da171fff44bb4a22cb82c98a5361d4a (patch)
tree5d88fbb4e2172726b5e89d5a1aacbf2ade9f20e9 /dev-perl/Finance-YahooQuote
parentdev-perl/Filesys-SmbClient: Add very basic tests (diff)
downloadgentoo-056e62af9da171fff44bb4a22cb82c98a5361d4a.tar.gz
gentoo-056e62af9da171fff44bb4a22cb82c98a5361d4a.tar.bz2
gentoo-056e62af9da171fff44bb4a22cb82c98a5361d4a.zip
dev-perl/Finance-YahooQuote: EAPI6 + tests
- EAPI6ify - Add basic tests - Gate network tests by DIST_TEST_OVERRRIDE Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'dev-perl/Finance-YahooQuote')
-rw-r--r--dev-perl/Finance-YahooQuote/Finance-YahooQuote-0.250.0-r1.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/dev-perl/Finance-YahooQuote/Finance-YahooQuote-0.250.0-r1.ebuild b/dev-perl/Finance-YahooQuote/Finance-YahooQuote-0.250.0-r1.ebuild
new file mode 100644
index 000000000000..c869fc47a9b7
--- /dev/null
+++ b/dev-perl/Finance-YahooQuote/Finance-YahooQuote-0.250.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=EDD
+DIST_VERSION=0.25
+inherit perl-module
+
+DESCRIPTION="Get stock quotes from Yahoo! Finance"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-perl/libwww-perl
+ virtual/perl-MIME-Base64
+ >=dev-perl/HTML-Parser-2.200.0
+ >=virtual/perl-Text-ParseWords-3.100.0
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+src_test() {
+ local MODULES=(
+ "Finance::YahooQuote ${DIST_VERSION}"
+ )
+ local failed=()
+ for dep in "${MODULES[@]}"; do
+ ebegin "Compile testing ${dep}"
+ perl -Mblib="${S}" -M"${dep} ()" -e1
+ eend $? || failed+=( "$dep" )
+ done
+ if [[ ${failed[@]} ]]; then
+ echo
+ eerror "One or more modules failed compile:";
+ for dep in "${failed[@]}"; do
+ eerror " ${dep}"
+ done
+ die "Failing due to module compilation errors";
+ fi
+ if ! has network ${DIST_TEST_OVERRIDE:-${DIST_TEST:-do parallel}}; then
+ ewarn "Comprehensive tests require network access. For details, see:"
+ ewarn "https://wiki.gentoo.org/wiki/Project:Perl/maint-notes/dev-perl/Finance-YahooQuote"
+ perl_rm_files "t/04custom.t" "t/02simple.t" "t/03extended.t" "t/05test.t";
+ fi
+ perl-module_src_test
+}