summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-30 17:08:02 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-10-30 17:12:51 +0200
commitd91d8d586034929003b311c173d53fbd7dbc8dd3 (patch)
treecf73b3d425405c4265388d568bc7db3343b2caae /dev-perl/Gearman-Server/Gearman-Server-1.130.1-r2.ebuild
parentdev-perl/Gearman-Client-Async: EAPI=8 bump (diff)
downloadgentoo-d91d8d586034929003b311c173d53fbd7dbc8dd3.tar.gz
gentoo-d91d8d586034929003b311c173d53fbd7dbc8dd3.tar.bz2
gentoo-d91d8d586034929003b311c173d53fbd7dbc8dd3.zip
dev-perl/Gearman-Server: EAPI=8 bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Gearman-Server/Gearman-Server-1.130.1-r2.ebuild')
-rw-r--r--dev-perl/Gearman-Server/Gearman-Server-1.130.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-perl/Gearman-Server/Gearman-Server-1.130.1-r2.ebuild b/dev-perl/Gearman-Server/Gearman-Server-1.130.1-r2.ebuild
new file mode 100644
index 000000000000..f6c19c7b5089
--- /dev/null
+++ b/dev-perl/Gearman-Server/Gearman-Server-1.130.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=PALIK
+DIST_VERSION=v${PV}
+inherit perl-module
+
+DESCRIPTION="Gearman distributed job system - worker/client connector"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+RDEPEND="
+ >=dev-perl/Danga-Socket-1.520.0
+ >=dev-perl/Gearman-1.07
+ !!sys-cluster/gearmand
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ dev-perl/Test-Script
+ )
+"
+
+PATCHES=( "${FILESDIR}/${P}-Use-saner-name-in-process-listing.patch" )
+
+src_install() {
+ perl-module_src_install
+ newinitd "${FILESDIR}"/gearmand-init.d-1.09 gearmand
+ newconfd "${FILESDIR}"/gearmand-conf.d-1.09 gearmand
+}