summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-09 18:34:59 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-05-09 18:34:59 +0200
commit859865c7a94745bc9b21e400060940bc89b00961 (patch)
tree9493b2d8aabbbfd5fa523433b11a7771a9dfdbee /dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild
parentdev-perl/Math-BigInt-GMP: Version bump 1.6007 (diff)
downloadgentoo-859865c7a94745bc9b21e400060940bc89b00961.tar.gz
gentoo-859865c7a94745bc9b21e400060940bc89b00961.tar.bz2
gentoo-859865c7a94745bc9b21e400060940bc89b00961.zip
dev-perl/Math-BigInt-Lite: Version bump 0.19
Closes: https://bugs.gentoo.org/774411 Package-Manager: Portage-3.0.18, Repoman-3.0.2 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild')
-rw-r--r--dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild
new file mode 100644
index 000000000000..9d6b448d94bd
--- /dev/null
+++ b/dev-perl/Math-BigInt-Lite/Math-BigInt-Lite-0.190.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=PJACKLAM
+DIST_VERSION=0.19
+inherit perl-module
+
+DESCRIPTION="What BigInts are before they become big"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=virtual/perl-Math-BigInt-1.999.812
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"
+
+src_test() {
+ local bad_files=( "t/pod_cov.t" "t/pod.t" )
+ perl_rm_files "${bad_files[@]}"
+ perl-module_src_test
+}