summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-perl/Moo
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-perl/Moo')
-rw-r--r--dev-perl/Moo/Manifest3
-rw-r--r--dev-perl/Moo/Moo-1.4.2.ebuild34
-rw-r--r--dev-perl/Moo/Moo-2.0.0.ebuild33
-rw-r--r--dev-perl/Moo/Moo-2.0.2.ebuild34
-rw-r--r--dev-perl/Moo/metadata.xml25
5 files changed, 129 insertions, 0 deletions
diff --git a/dev-perl/Moo/Manifest b/dev-perl/Moo/Manifest
new file mode 100644
index 000000000000..0b9f0ce8e96b
--- /dev/null
+++ b/dev-perl/Moo/Manifest
@@ -0,0 +1,3 @@
+DIST Moo-1.004002.tar.gz 80226 SHA256 d32b61b8e85795b302afdf3bc684239a6f8f3b4b8896ada96298164703085183 SHA512 b6a179cb3c6adc80e51c542eccbac4d6e781bd0de927db7cdad75502cc6d9527d6eebeabd9ede6c40d581ad8bcf435435151b953098f8c4e8a7fc8716b7f842d WHIRLPOOL 7ecb9ff164432698ca3c3cc0833ab979841c3fe0ae499eea1ff94fde224e8aee8f5bd0bec5477f8ff5d69a8d1aa8f72266b9d4844a814852f1081f2412f99b54
+DIST Moo-2.000000.tar.gz 92576 SHA256 57a743bba2e51568c83d00eb3b91d76767069b0fb3d06ef5407bb527b8f35de5 SHA512 1eaabd0a8f0dc0273a33988c7194ab43fa9e1cef24d1cd93c176ca43c445638f6c777999c7f01d6467bf9f9455ebbcfc22797447ff34543ea617bf402a5667c6 WHIRLPOOL 0223cd492f0fa5cbadba4a173c0fab7c86efc0613f360cfaf5237697396e62beb014880b995c2f862d13919d9435a17f3b8711fbb08f6611d4a6634e073b802e
+DIST Moo-2.000002.tar.gz 94253 SHA256 fb4bfa751f0dd06bd70f2e06e811f85a640501f263c228a8efafbf6b26691fd4 SHA512 dbafbe0fe976492bc98610591c80d6f5c19c33b61a4d1cf4752ee03b7ceedf5ff5a5ef789436adf49a697508dde7db8a58dafbcec9ac88780b75896cb0dc072c WHIRLPOOL e811e0785f1ec5155d9aa90112f2c04a62d9d00c3f04cb9f8533812ac94592d60b1bb3eb0bfb4e889a776967b6ab9ed45869453d8d59801934b4fa7404f574a0
diff --git a/dev-perl/Moo/Moo-1.4.2.ebuild b/dev-perl/Moo/Moo-1.4.2.ebuild
new file mode 100644
index 000000000000..52a6eaaa8577
--- /dev/null
+++ b/dev-perl/Moo/Moo-1.4.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HAARG
+MODULE_VERSION=1.004002
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=dev-perl/Devel-GlobalDestruction-0.110.0
+ >=dev-perl/Dist-CheckConflicts-0.20.0
+ >=dev-perl/Import-Into-1.2.0
+ >=dev-perl/Module-Runtime-0.12.0
+ >=dev-perl/Role-Tiny-1.3.2
+ >=dev-perl/strictures-1.4.3
+ >=dev-lang/perl-5.8.1
+"
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.94
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Moo/Moo-2.0.0.ebuild b/dev-perl/Moo/Moo-2.0.0.ebuild
new file mode 100644
index 000000000000..563f1b81f0f0
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.0.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HAARG
+MODULE_VERSION=2.000000
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=dev-perl/Devel-GlobalDestruction-0.110.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Module-Runtime-0.14.0
+ >=dev-perl/Role-Tiny-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.94
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Moo/Moo-2.0.2.ebuild b/dev-perl/Moo/Moo-2.0.2.ebuild
new file mode 100644
index 000000000000..fc9c8c8f02a0
--- /dev/null
+++ b/dev-perl/Moo/Moo-2.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+MODULE_AUTHOR=HAARG
+MODULE_VERSION=2.000002
+inherit perl-module
+
+DESCRIPTION="Minimalist Object Orientation (with Moose compatiblity)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~x86 ~ppc-aix ~ppc-macos ~x86-solaris"
+IUSE="test"
+
+# needs Scalar::Util
+RDEPEND="
+ >=dev-perl/Class-Method-Modifiers-1.100.0
+ >=dev-perl/Devel-GlobalDestruction-0.110.0
+ >=virtual/perl-Exporter-5.570.0
+ >=dev-perl/Module-Runtime-0.14.0
+ >=dev-perl/Role-Tiny-2.0.0
+ virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=dev-perl/Test-Fatal-0.3.0
+ >=virtual/perl-Test-Simple-0.940.0
+ )
+"
+
+SRC_TEST="do parallel"
diff --git a/dev-perl/Moo/metadata.xml b/dev-perl/Moo/metadata.xml
new file mode 100644
index 000000000000..c570f0ad7a43
--- /dev/null
+++ b/dev-perl/Moo/metadata.xml
@@ -0,0 +1,25 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>perl</herd>
+ <upstream>
+ <remote-id type="cpan">Moo</remote-id>
+ <remote-id type="cpan-module">Method::Generate::Accessor</remote-id>
+ <remote-id type="cpan-module">Method::Generate::BuildAll</remote-id>
+ <remote-id type="cpan-module">Method::Generate::Constructor</remote-id>
+ <remote-id type="cpan-module">Method::Generate::DemolishAll</remote-id>
+ <remote-id type="cpan-module">Method::Inliner</remote-id>
+ <remote-id type="cpan-module">Moo</remote-id>
+ <remote-id type="cpan-module">Moo::HandleMoose</remote-id>
+ <remote-id type="cpan-module">Moo::HandleMoose::FakeConstructor</remote-id>
+ <remote-id type="cpan-module">Moo::HandleMoose::FakeMetaClass</remote-id>
+ <remote-id type="cpan-module">Moo::Object</remote-id>
+ <remote-id type="cpan-module">Moo::Role</remote-id>
+ <remote-id type="cpan-module">Moo::_Utils</remote-id>
+ <remote-id type="cpan-module">Moo::_mro</remote-id>
+ <remote-id type="cpan-module">Moo::sification</remote-id>
+ <remote-id type="cpan-module">Sub::Defer</remote-id>
+ <remote-id type="cpan-module">Sub::Quote</remote-id>
+ <remote-id type="cpan-module">oo</remote-id>
+ </upstream>
+</pkgmetadata>