summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-15 05:16:56 +1300
committerAndreas K. Hüttel <dilfridge@gentoo.org>2016-03-15 00:06:37 +0100
commit0d3f0b97b52ee804acbbdda6e4f6c6bcce686af7 (patch)
treee0fc5897a71c6c577141df02b087ec714478a634 /dev-perl/Palm/Palm-1.400.0.ebuild
parentdev-perl/Palm-PDB: Added to tree at version 1.400.0 (diff)
downloadgentoo-0d3f0b97b52ee804acbbdda6e4f6c6bcce686af7.tar.gz
gentoo-0d3f0b97b52ee804acbbdda6e4f6c6bcce686af7.tar.bz2
gentoo-0d3f0b97b52ee804acbbdda6e4f6c6bcce686af7.zip
dev-perl/Palm: Bump to version 1.400.0
- EAPI6 - First real post-migration version where PN=Upstream - DESCRIPTION updated - LICENSE updated - Added "examples" USE - Tests cleaned up Upstream: - Palm::Raw and Palm::PDB split into dev-perl/Palm-PDB Needs Re-Keywording for: ~alpha ~ppc Including: dev-perl/Palm-PDB-1.400.0 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Palm/Palm-1.400.0.ebuild')
-rw-r--r--dev-perl/Palm/Palm-1.400.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-perl/Palm/Palm-1.400.0.ebuild b/dev-perl/Palm/Palm-1.400.0.ebuild
new file mode 100644
index 000000000000..ad037725a341
--- /dev/null
+++ b/dev-perl/Palm/Palm-1.400.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=CJM
+DIST_VERSION=1.400
+inherit perl-module
+
+DESCRIPTION="Read & write Palm OS databases (both PDB and PRC)"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test examples"
+
+# Palm::Raw -> Palm-PDB
+RDEPEND="
+ virtual/perl-Exporter
+ dev-perl/Palm-PDB
+"
+DEPEND="
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files "t/pod.t" "t/pod_coverage.t"
+ perl-module_src_test
+}
+src_install() {
+ perl-module_src_install
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}/examples/
+ doins -r examples/*
+ fi
+}