summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-26 20:44:56 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:09 +1300
commitf927ce1fbbde6b02b2e20f1318c7b9a205582fba (patch)
tree8fbafa0b15698645c70be8948926999206e622d3 /dev-perl/Path-Class/Path-Class-0.370.0.ebuild
parentdev-perl/Parse-Yapp: Bump to version 1.210.0 (diff)
downloadgentoo-f927ce1fbbde6b02b2e20f1318c7b9a205582fba.tar.gz
gentoo-f927ce1fbbde6b02b2e20f1318c7b9a205582fba.tar.bz2
gentoo-f927ce1fbbde6b02b2e20f1318c7b9a205582fba.zip
dev-perl/Path-Class: Bump to version 0.370.0
Upstream: - Doc fixes - Fix 'contains' when $self is relative - Handle $other being falsy Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Path-Class/Path-Class-0.370.0.ebuild')
-rw-r--r--dev-perl/Path-Class/Path-Class-0.370.0.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-perl/Path-Class/Path-Class-0.370.0.ebuild b/dev-perl/Path-Class/Path-Class-0.370.0.ebuild
new file mode 100644
index 000000000000..4315c29e476f
--- /dev/null
+++ b/dev-perl/Path-Class/Path-Class-0.370.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=KWILLIAMS
+DIST_VERSION=0.37
+inherit perl-module
+
+DESCRIPTION="Cross-platform path specification manipulation"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~ppc-aix ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ virtual/perl-File-Path
+ >=virtual/perl-File-Spec-3.260.0
+ virtual/perl-File-Temp
+ virtual/perl-IO
+ virtual/perl-Perl-OSType
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-parent
+"
+DEPEND="${RDEPEND}
+ >=dev-perl/Module-Build-0.360.100
+ >=virtual/perl-ExtUtils-MakeMaker-6.300.0
+ test? (
+ virtual/perl-Test
+ virtual/perl-Test-Simple
+ )
+"
+src_test() {
+ perl_rm_files "t/author-critic.t"
+ perl-module_src_test
+}