summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-12-26 21:01:01 +1300
committerKent Fredric <kentnl@gentoo.org>2017-12-26 21:48:10 +1300
commitf3da4f54cdc121a861f2b42bcf208a545b6d4148 (patch)
tree975eb7bc3b426030b22e3ee48f525e4030814f3c /dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
parentdev-perl/Pegex: Bump to version 0.640.0 (diff)
downloadgentoo-f3da4f54cdc121a861f2b42bcf208a545b6d4148.tar.gz
gentoo-f3da4f54cdc121a861f2b42bcf208a545b6d4148.tar.bz2
gentoo-f3da4f54cdc121a861f2b42bcf208a545b6d4148.zip
dev-perl/Perl-Tidy: Bump to version 20171214.0.0
Upstream: - Continuation indentation now outdents closing parens in call chains - Add control flag for space between backslash and single/double quote - Add support for 5.26+ indented heredoc operator - Fix failure to call binmode - Fix using three-dot for locating config files using ENV - Improve vertical alignment - Stop vertically alignining // Package-Manager: Portage-2.3.18, Repoman-2.3.6
Diffstat (limited to 'dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild')
-rw-r--r--dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild b/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
new file mode 100644
index 000000000000..b3ffc3289260
--- /dev/null
+++ b/dev-perl/Perl-Tidy/Perl-Tidy-20171214.0.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=SHANCOCK
+DIST_VERSION=20171214
+DIST_EXAMPLES=( "examples/*" )
+inherit perl-module
+
+DESCRIPTION="Perl script indenter and beautifier"
+HOMEPAGE="http://perltidy.sourceforge.net/ ${HOMEPAGE}"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~sparc-solaris"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+src_install() {
+ perl-module_src_install
+
+ # Compressing pod is bad because perldoc can't decompress
+ # bzip2 automatically, and `less` can't render perldoc
+ docompress -x /usr/share/doc/${PF}/stylekey.pod
+ docompress -x /usr/share/doc/${PF}/tutorial
+
+ docinto ''
+ dodoc docs/stylekey.pod
+
+ docinto tutorial
+ dodoc docs/tutorial.pod docs/testfile.pl
+}