summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-10 19:45:21 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2021-08-10 20:23:30 +0200
commit67c0a90436735f3f7e4b46218e246aeda053f34e (patch)
tree18563122cdeb2779d138316b5a3f10dc6fa69755 /dev-perl/Sub-Identify/Sub-Identify-0.140.0-r1.ebuild
parentdev-perl/Sub-Exporter-Progressive: EAPI=8 bump (diff)
downloadgentoo-67c0a90436735f3f7e4b46218e246aeda053f34e.tar.gz
gentoo-67c0a90436735f3f7e4b46218e246aeda053f34e.tar.bz2
gentoo-67c0a90436735f3f7e4b46218e246aeda053f34e.zip
dev-perl/Sub-Identify: EAPI=8 bump
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'dev-perl/Sub-Identify/Sub-Identify-0.140.0-r1.ebuild')
-rw-r--r--dev-perl/Sub-Identify/Sub-Identify-0.140.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Sub-Identify/Sub-Identify-0.140.0-r1.ebuild b/dev-perl/Sub-Identify/Sub-Identify-0.140.0-r1.ebuild
new file mode 100644
index 000000000000..0f288b92a4b2
--- /dev/null
+++ b/dev-perl/Sub-Identify/Sub-Identify-0.140.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=RGARCIA
+DIST_VERSION=0.14
+inherit perl-module
+
+DESCRIPTION="Retrieve names of code references"
+
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+RDEPEND="
+ virtual/perl-Exporter
+ virtual/perl-XSLoader
+"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ virtual/perl-Scalar-List-Utils
+ virtual/perl-Test-Simple
+ )
+"
+
+src_test() {
+ perl_rm_files "t/pod.t"
+ perl-module_src_test
+}