summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-01 23:43:08 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-01 23:43:08 +1200
commit7a8a3468a8ce6207f46c0a7f03a76984c93e89fa (patch)
treec02ae855e9d5466e98e13356654594c974fefd27 /dev-perl
parentdev-perl/Crypt-OpenSSL-Bignum: -r1 bump for EAPI7 + fixes (diff)
downloadgentoo-7a8a3468a8ce6207f46c0a7f03a76984c93e89fa.tar.gz
gentoo-7a8a3468a8ce6207f46c0a7f03a76984c93e89fa.tar.bz2
gentoo-7a8a3468a8ce6207f46c0a7f03a76984c93e89fa.zip
dev-perl/Crypt-OpenSSL-DSA: -r bump for EAPI7 + fixes
- EAPI7 - Ensure CFLAGS passed through to compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl')
-rw-r--r--dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r2.ebuild b/dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r2.ebuild
new file mode 100644
index 000000000000..f9674d7a6f43
--- /dev/null
+++ b/dev-perl/Crypt-OpenSSL-DSA/Crypt-OpenSSL-DSA-0.190.0-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+DIST_AUTHOR=KMX
+DIST_VERSION=0.19
+inherit perl-module
+
+DESCRIPTION="Digital Signature Algorithm using OpenSSL"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( dev-libs/openssl:0 )
+ libressl? ( >=dev-libs/libressl-2.7.2 )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+"
+
+DIST_TEST=do
+# otherwise random fails occur
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}