summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-php/pecl-event
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-php/pecl-event')
-rw-r--r--dev-php/pecl-event/Manifest3
-rw-r--r--dev-php/pecl-event/metadata.xml13
-rw-r--r--dev-php/pecl-event/pecl-event-1.11.1.ebuild42
-rw-r--r--dev-php/pecl-event/pecl-event-1.7.8.ebuild40
-rw-r--r--dev-php/pecl-event/pecl-event-1.8.0.ebuild42
5 files changed, 140 insertions, 0 deletions
diff --git a/dev-php/pecl-event/Manifest b/dev-php/pecl-event/Manifest
new file mode 100644
index 000000000000..a0b4d354a486
--- /dev/null
+++ b/dev-php/pecl-event/Manifest
@@ -0,0 +1,3 @@
+DIST event-1.11.1.tgz 78942 SHA256 371e8d559461542058efd57be61fd8316121985dc455f2e7979722e37cedd526 SHA512 95db37aa339b7530b3636835191be12eceefa23e2b511b84c7654556145ce1e198bb81299380bb742b1edfc0e32222c96d81f5f2f6f2f19d41d636dc9f517480 WHIRLPOOL d0a1104d418a218e0b4311b02d05ae2a8e47ab3039047a2bae320d7e19f87b4aade28c0755741077e9380d29cdc626a250c75dd7fe75bffb6ac3ca235a5435c2
+DIST event-1.7.8.tgz 69828 SHA256 3b637b3c66c8e2311c16e79fb8e90a7a02bd0df08a25514d1445f1e648d1c58a SHA512 1f2128d2a7f84ad4a3b761dfb63ae5932ffe8b5b5faa20f8d0fc17ede807b5c44a6fe8589a0257fe7d4313f6c2df5332519a4c2bab9fb498c36cdf53564b5117 WHIRLPOOL 7cf81434e3d1b2c92adb9d2667f4fea77bbb16bac6771f7e85fcf69cae54729cc9a7cc1f1b1670c667a679037cf40aa37d78a2713cd1c1e919e5bf272cb0211a
+DIST event-1.8.0.tgz 71640 SHA256 34ecc3f2367ac843b1764e9939cc511646364985165d743d538ff55043551682 SHA512 11d3deef376b699d9bab4477f1075a9464a5247048472a856ef8ebd74fa56dee8750c308fa615a08289d1d17415847a6671916ea11d0a6dd8781064aca6b7414 WHIRLPOOL a4addd4b250ca58186702edf926133bea2bb6f4d297f669cc794f9fc511ffc8f6e2904ca1c9f0418421356ce4b4505e646beec5003cd93e92c6af0373ed057ad
diff --git a/dev-php/pecl-event/metadata.xml b/dev-php/pecl-event/metadata.xml
new file mode 100644
index 000000000000..eb88016a77f4
--- /dev/null
+++ b/dev-php/pecl-event/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>proxy-maintainers</herd>
+<maintainer>
+<email>rrosmanov@gmail.com</email>
+<name>Ruslan Osmanov</name>
+<description>Maintainer. Assign bugs to him</description>
+</maintainer>
+<use>
+<flag name="extra">Add support of the Libevent extra API</flag>
+</use>
+</pkgmetadata>
diff --git a/dev-php/pecl-event/pecl-event-1.11.1.ebuild b/dev-php/pecl-event/pecl-event-1.11.1.ebuild
new file mode 100644
index 000000000000..a72f222bdaf4
--- /dev/null
+++ b/dev-php/pecl-event/pecl-event-1.11.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="event"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL INSTALL.md README.md LICENSE"
+
+USE_PHP="php5-4 php5-5 php5-6"
+
+inherit php-ext-pecl-r2 confutils eutils
+
+KEYWORDS="amd64 ia64 x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libevent2"
+LICENSE="PHP-3"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/libevent-2.0.2
+ !dev-php/pecl-libevent
+ sockets? ( dev-lang/php:*[sockets] )"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug +extra +ssl threads +sockets examples"
+
+src_configure() {
+ my_conf="--with-event-core"
+ enable_extension_enable "event-debug" "debug" 0
+
+ enable_extension_with "event-extra" "extra" 1
+ enable_extension_with "event-openssl" "ssl" 1
+ enable_extension_with "event-pthreads" "threads" 0
+ enable_extension_enable "event-sockets" "sockets" 1
+
+ php-ext-source-r2_src_configure
+}
diff --git a/dev-php/pecl-event/pecl-event-1.7.8.ebuild b/dev-php/pecl-event/pecl-event-1.7.8.ebuild
new file mode 100644
index 000000000000..b5498968f997
--- /dev/null
+++ b/dev-php/pecl-event/pecl-event-1.7.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+PHP_EXT_NAME="event"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL INSTALL.md README.md LICENSE"
+
+USE_PHP="php5-4 php5-5"
+inherit php-ext-pecl-r2 confutils eutils
+
+KEYWORDS="~amd64 ~x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libevent2"
+LICENSE="PHP-3"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+ >=dev-libs/libevent-2.0.2
+ !dev-php/pecl-libevent
+ sockets? ( dev-lang/php[sockets] )"
+RDEPEND="${DEPEND}"
+
+IUSE="debug +extra +ssl threads +sockets examples"
+
+src_configure() {
+ my_conf="--with-event-core"
+ enable_extension_enable "event-debug" "debug" 0
+
+ enable_extension_with "event-extra" "extra" 1
+ enable_extension_with "event-openssl" "ssl" 1
+ enable_extension_with "event-pthreads" "threads" 0
+ enable_extension_enable "event-sockets" "sockets" 1
+
+ php-ext-source-r2_src_configure
+}
diff --git a/dev-php/pecl-event/pecl-event-1.8.0.ebuild b/dev-php/pecl-event/pecl-event-1.8.0.ebuild
new file mode 100644
index 000000000000..33403a1c92bd
--- /dev/null
+++ b/dev-php/pecl-event/pecl-event-1.8.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+PHP_EXT_NAME="event"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+DOCS="CREDITS EXPERIMENTAL INSTALL.md README.md LICENSE"
+
+USE_PHP="php5-4 php5-5"
+
+inherit php-ext-pecl-r2 confutils eutils
+
+KEYWORDS="amd64 ia64 x86"
+LICENSE="PHP-3.01"
+
+DESCRIPTION="PHP wrapper for libevent2"
+LICENSE="PHP-3"
+SLOT="0"
+
+DEPEND="
+ >=dev-libs/libevent-2.0.2
+ !dev-php/pecl-libevent
+ sockets? ( dev-lang/php:*[sockets] )"
+
+RDEPEND="${DEPEND}"
+
+IUSE="debug +extra +ssl threads +sockets examples"
+
+src_configure() {
+ my_conf="--with-event-core"
+ enable_extension_enable "event-debug" "debug" 0
+
+ enable_extension_with "event-extra" "extra" 1
+ enable_extension_with "event-openssl" "ssl" 1
+ enable_extension_with "event-pthreads" "threads" 0
+ enable_extension_enable "event-sockets" "sockets" 1
+
+ php-ext-source-r2_src_configure
+}