summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2022-01-20 11:10:40 -0500
committerBrian Evans <grknight@gentoo.org>2022-01-20 11:21:15 -0500
commitd09f389970a1a1f1dca74e62b4cb7d5e88a02ceb (patch)
treec02f554e41a08782eafb18bc47fdd2243a5ca1dd /dev-php/pecl-pam/pecl-pam-2.2.4.ebuild
parentdev-php/pecl-lzf: Version bump for 1.7.0 (diff)
downloadgentoo-d09f389970a1a1f1dca74e62b4cb7d5e88a02ceb.tar.gz
gentoo-d09f389970a1a1f1dca74e62b4cb7d5e88a02ceb.tar.bz2
gentoo-d09f389970a1a1f1dca74e62b4cb7d5e88a02ceb.zip
dev-php/pecl-pam: Version bump for 2.2.4
Signed-off-by: Brian Evans <grknight@gentoo.org>
Diffstat (limited to 'dev-php/pecl-pam/pecl-pam-2.2.4.ebuild')
-rw-r--r--dev-php/pecl-pam/pecl-pam-2.2.4.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/pecl-pam/pecl-pam-2.2.4.ebuild b/dev-php/pecl-pam/pecl-pam-2.2.4.ebuild
new file mode 100644
index 000000000000..4a809c31272d
--- /dev/null
+++ b/dev-php/pecl-pam/pecl-pam-2.2.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PHP_EXT_NAME="pam"
+PHP_EXT_INI="yes"
+PHP_EXT_ZENDEXT="no"
+PHP_EXT_ECONF_ARGS=( --with-pam=/usr )
+DOCS=( README )
+
+USE_PHP="php7-3 php7-4 php8-0 php8-1"
+
+inherit php-ext-pecl-r3 pam
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="This extension provides PAM (Pluggable Authentication Modules) integration"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="sys-libs/pam"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ #Fix DOS line endings
+ sed -i 's/\r$//' -- pam.c || die
+ php-ext-source-r3_src_prepare
+}
+
+src_install() {
+ pamd_mimic_system php auth account password
+ php-ext-pecl-r3_src_install
+}