summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2018-02-20 13:45:36 -0500
committerBrian Evans <grknight@gentoo.org>2018-02-20 14:28:50 -0500
commit2e7e9b91102abc178b6ef1153a4c2d851699dae0 (patch)
tree6292acde2e4c333f4f905e284c5517cc09a32acd /dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
parentdev-php/phing: Drop old (diff)
downloadgentoo-2e7e9b91102abc178b6ef1153a4c2d851699dae0.tar.gz
gentoo-2e7e9b91102abc178b6ef1153a4c2d851699dae0.tar.bz2
gentoo-2e7e9b91102abc178b6ef1153a4c2d851699dae0.zip
dev-php/phpDocumentor: Version bump to 2.9.0
Includes php 7 syntax support Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild')
-rw-r--r--dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
new file mode 100644
index 000000000000..dac43364c339
--- /dev/null
+++ b/dev-php/phpDocumentor/phpDocumentor-2.9.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Automatic documenting of php api directly from the source"
+HOMEPAGE="http://phpdoc.org"
+SRC_URI="https://github.com/${PN}/${PN}2/releases/download/v${PV}/${PN}.phar -> ${P}.phar"
+
+LICENSE="MIT"
+SLOT="0"
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+# block old version that provides the same binary
+DEPEND="!dev-php/PEAR-PhpDocumentor"
+RDEPEND="media-gfx/graphviz
+ dev-lang/php:*[cli,iconv,intl,phar,xmlreader,xslt]"
+S="${WORKDIR}"
+
+src_unpack() { :; }
+
+src_install() {
+ exeinto /usr/share/php/${PN}
+ newexe "${DISTDIR}/${P}.phar" ${PN}.phar
+ dosym "../share/php/${PN}/${PN}.phar" /usr/bin/phpdoc
+}