summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-05-28 10:56:29 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-05-28 10:58:55 +0200
commitd5ebd6bf4c1d4cdce4f09ae744249840eb6a345a (patch)
treee12f43f9c857221d7c3d1fd2eb03bae3de1d551f /dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
parentsys-cluster/singularity: drop 3.7.3 (diff)
downloadgentoo-d5ebd6bf4c1d4cdce4f09ae744249840eb6a345a.tar.gz
gentoo-d5ebd6bf4c1d4cdce4f09ae744249840eb6a345a.tar.bz2
gentoo-d5ebd6bf4c1d4cdce4f09ae744249840eb6a345a.zip
dev-php/xdebug-handler: bump to v2.0.1
Package-Manager: Portage-3.0.19, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild')
-rw-r--r--dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild b/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
new file mode 100644
index 000000000000..ad9f7604ad52
--- /dev/null
+++ b/dev-php/xdebug-handler/xdebug-handler-2.0.1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Restart a CLI process without loading the xdebug extension"
+HOMEPAGE="https://github.com/composer/xdebug-handler"
+SRC_URI="https://github.com/composer/xdebug-handler/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-lang/php:*
+ dev-php/fedora-autoloader
+ >=dev-php/psr-log-1.0.2"
+
+src_install() {
+ insinto /usr/share/php/Composer/XdebugHandler
+ doins src/*.php "${FILESDIR}/autoload.php"
+ dodoc README.md
+}