summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomáš Mózes <hydrapolic@gmail.com>2024-11-18 14:21:16 +0000
committerMichael Orlitzky <mjo@gentoo.org>2024-11-23 23:05:04 -0500
commit5a53c64515a0016aa8ebcb39c2812eaab9eae496 (patch)
tree924e666b6f036758eb1d11648a77c4286e74207e /dev-php
parentprofiles/arch/amd64: re-un-unmask USE=oci8-instant-client on amd64 (diff)
downloadgentoo-5a53c64515a0016aa8ebcb39c2812eaab9eae496.tar.gz
gentoo-5a53c64515a0016aa8ebcb39c2812eaab9eae496.tar.bz2
gentoo-5a53c64515a0016aa8ebcb39c2812eaab9eae496.zip
dev-php/pecl-uploadprogress: add php 8.3 support
Bug: https://bugs.gentoo.org/943650 Closes: https://github.com/gentoo/gentoo/pull/39360 Signed-off-by: Tomáš Mózes <hydrapolic@gmail.com> Signed-off-by: Michael Orlitzky <mjo@gentoo.org>
Diffstat (limited to 'dev-php')
-rw-r--r--dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2-r2.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2-r2.ebuild b/dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2-r2.ebuild
new file mode 100644
index 000000000000..72972003e9ab
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/pecl-uploadprogress-2.0.2-r2.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+USE_PHP="php8-2 php8-3"
+PHP_EXT_SAPIS="apache2 fpm"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="An extension to track progress of a file upload"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+PATCHES=( "${FILESDIR}/php-debug-testfix.patch" )
+
+RDEPEND="
+ php_targets_php8-2? ( || ( dev-lang/php:8.2[apache2(-),fileinfo(-)] dev-lang/php:8.2[fileinfo(-),fpm(-)] ) )
+ php_targets_php8-3? ( || ( dev-lang/php:8.3[apache2(-),fileinfo(-)] dev-lang/php:8.3[fileinfo(-),fpm(-)] ) )
+"