summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-22 20:25:12 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-22 20:30:36 +0100
commit96935f5fba56b28a1b32f5ce2e4463699dd9ab4a (patch)
tree845f21966242c5739fe6cd690670a4068343271f /dev-python/Opcodes
parentdev-python/Nuitka: Add PYPI_PN prior to rename (diff)
downloadgentoo-96935f5fba56b28a1b32f5ce2e4463699dd9ab4a.tar.gz
gentoo-96935f5fba56b28a1b32f5ce2e4463699dd9ab4a.tar.bz2
gentoo-96935f5fba56b28a1b32f5ce2e4463699dd9ab4a.zip
dev-python/Opcodes: Add MY_P prior to rename
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Opcodes')
-rw-r--r--dev-python/Opcodes/Manifest2
-rw-r--r--dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild24
2 files changed, 16 insertions, 10 deletions
diff --git a/dev-python/Opcodes/Manifest b/dev-python/Opcodes/Manifest
index 52680bec04bb..ab797e881a51 100644
--- a/dev-python/Opcodes/Manifest
+++ b/dev-python/Opcodes/Manifest
@@ -1 +1 @@
-DIST Opcodes-0.3.14.gh.tar.gz 236187 BLAKE2B 76e2f92a8860dc0306b5c48de9f64d6cd18e553af3936faac36e412bae129399ce7ff34ee2757b816a361aa29cdd45ac6b11e00bcaefd943e512ada6da0b70bc SHA512 bbdc08a75028c94def56b2afee0742db999acc8fe44aeeb6e8d8ac5e47e969a9daf0477e089ffff4c434be01c48b5e5ec5403bea86ba4e8674063a9f96fbeca8
+DIST Opcodes-0f7c7d63f5e13ce5a89d9acc3934f1b6e247ec1f.gh.tar.gz 236187 BLAKE2B 76e2f92a8860dc0306b5c48de9f64d6cd18e553af3936faac36e412bae129399ce7ff34ee2757b816a361aa29cdd45ac6b11e00bcaefd943e512ada6da0b70bc SHA512 bbdc08a75028c94def56b2afee0742db999acc8fe44aeeb6e8d8ac5e47e969a9daf0477e089ffff4c434be01c48b5e5ec5403bea86ba4e8674063a9f96fbeca8
diff --git a/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild b/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild
index b4257018de20..79d0c726e299 100644
--- a/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild
+++ b/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild
@@ -1,30 +1,36 @@
-# Copyright 2022-2023 Gentoo Authors
+# Copyright 2022-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..12} )
-inherit distutils-r1
+PYTHON_COMPAT=( python3_{10..12} )
-CommitId=0f7c7d63f5e13ce5a89d9acc3934f1b6e247ec1f
+inherit distutils-r1
+EGIT_COMMIT=0f7c7d63f5e13ce5a89d9acc3934f1b6e247ec1f
+MY_P=${PN^}-${EGIT_COMMIT}
DESCRIPTION="Opcodes Project"
HOMEPAGE="
+ https://github.com/Maratyszcza/Opcodes/
https://pypi.org/project/Opcodes/
"
-SRC_URI="https://github.com/Maratyszcza/${PN}/archive/${CommitId}.tar.gz
- -> ${P}.gh.tar.gz"
-S="${WORKDIR}"/${PN}-${CommitId}
+SRC_URI="
+ https://github.com/Maratyszcza/Opcodes/archive/${EGIT_COMMIT}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
LICENSE="BSD-2"
SLOT="0"
KEYWORDS="~amd64"
RESTRICT="test" # depends on an old version of werkzeug
-RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
-DOCS=readme.rst
+DOCS=( readme.rst )
distutils_enable_sphinx sphinx \
dev-python/sphinx-bootstrap-theme