summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2023-02-09 22:50:54 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2023-02-10 00:26:27 +0100
commitc33b26139bdcab17fd76f0a3a5028b2f0b07eebc (patch)
tree876fc365bb3844cf6a1786d3a8916283cac4a9f1 /dev-python/aiocache/aiocache-0.12.0.ebuild
parentwww-client/vivaldi-snapshot: Drop old 5.7.2914.3 (diff)
downloadgentoo-c33b26139bdcab17fd76f0a3a5028b2f0b07eebc.tar.gz
gentoo-c33b26139bdcab17fd76f0a3a5028b2f0b07eebc.tar.bz2
gentoo-c33b26139bdcab17fd76f0a3a5028b2f0b07eebc.zip
dev-python/aiocache: new package, add 0.12.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'dev-python/aiocache/aiocache-0.12.0.ebuild')
-rw-r--r--dev-python/aiocache/aiocache-0.12.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/aiocache/aiocache-0.12.0.ebuild b/dev-python/aiocache/aiocache-0.12.0.ebuild
new file mode 100644
index 000000000000..ac1baf19bf02
--- /dev/null
+++ b/dev-python/aiocache/aiocache-0.12.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Asyncio cache manager"
+HOMEPAGE="https://github.com/aio-libs/aiocache/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+# TODO add optional cache systems deps (and new package aiomcache)
+# Tests require all backends
+RESTRICT="test"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${PN}-0.12.0-fix-test-installation.patch" )
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}