summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-16 08:10:01 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-16 09:17:38 +0100
commit16955fa114a0749cb8288cd62eaac087f19ab9a5 (patch)
treec3b0b067ce75df5a536d08b78c54696e3ec0fb91 /dev-python/apispec/apispec-6.6.0.ebuild
parentdev-python/dask: Bump to 2024.3.1 (diff)
downloadgentoo-16955fa114a0749cb8288cd62eaac087f19ab9a5.tar.gz
gentoo-16955fa114a0749cb8288cd62eaac087f19ab9a5.tar.bz2
gentoo-16955fa114a0749cb8288cd62eaac087f19ab9a5.zip
dev-python/apispec: Bump to 6.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec/apispec-6.6.0.ebuild')
-rw-r--r--dev-python/apispec/apispec-6.6.0.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/apispec/apispec-6.6.0.ebuild b/dev-python/apispec/apispec-6.6.0.ebuild
new file mode 100644
index 000000000000..7d9e2538b1f3
--- /dev/null
+++ b/dev-python/apispec/apispec-6.6.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pluggable API specification generator"
+HOMEPAGE="
+ https://github.com/marshmallow-code/apispec/
+ https://pypi.org/project/apispec/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.18.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx-rtd-theme
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}