summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-25 15:47:17 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-25 16:05:36 +0200
commit11b13e21ad79db7af2db4588f72bc7ff099fe3cb (patch)
treea44b00cc66b46ad9c16506bee0a0e48b8758f8a3 /dev-python/apsw
parentdev-java/openjdk-jre-bin: remove JDK_HOME and JAVAC from vm env file (diff)
downloadgentoo-11b13e21ad79db7af2db4588f72bc7ff099fe3cb.tar.gz
gentoo-11b13e21ad79db7af2db4588f72bc7ff099fe3cb.tar.bz2
gentoo-11b13e21ad79db7af2db4588f72bc7ff099fe3cb.zip
dev-python/apsw: Bump to 3.38.1_p1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.38.1_p1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index c47a63dd74fa..1a87533fa152 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1 +1,2 @@
DIST apsw-3.35.4_p1.zip 685034 BLAKE2B 5845e5fcb286c587367955c33fbee9aa4b0687af666f1d50f35f5dec8e756a0fbcf0fdbd120dd3c7a78df1f05d8eae5a973a8a71fc8a6f4271fff7d83b399013 SHA512 f420560e5821bd6305705ee6c14174f1770f4811edcfe152cb1f2ceae4295f13c82552386a7ef42c5ce88165e88bd2080b4dc2809484598522914d99f2469135
+DIST apsw-3.38.1-r1.gh.tar.gz 338985 BLAKE2B aa0ef335bd3abc708b41a92959f98b4fd3961168feacb9ca6d382e0279c46d4227a8e09373721ae1361fcc38181376664130b3623b2f36e1596467b99959ecb8 SHA512 4d161641d7bf7f933507e7d7e71d437d9db95f7327e29cf34848d9b741e2711dafbefbf19cb34d78d83b4e69115acad855f924fdf80de1cea4c9d61fe0f2b670
diff --git a/dev-python/apsw/apsw-3.38.1_p1.ebuild b/dev-python/apsw/apsw-3.38.1_p1.ebuild
new file mode 100644
index 000000000000..64f34312b92b
--- /dev/null
+++ b/dev-python/apsw/apsw-3.38.1_p1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_PV=${PV/_p/-r}
+MY_P=${PN}-${MY_PV}
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${MY_PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%_p*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-3.6.20.1-fix_tests.patch"
+)
+
+python_compile() {
+ distutils-r1_python_compile --enable=load_extension
+ mv "${BUILD_DIR}/install${EPREFIX}/usr/apsw.pyi" \
+ "${BUILD_DIR}/install$(python_get_sitedir)" || die
+}
+
+python_test() {
+ esetup.py build_test_extension
+ "${EPYTHON}" tests.py -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}