summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-27 05:30:02 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-27 05:30:02 +0200
commit501e948b8361cb84a09fb4efd06f10f277db5775 (patch)
treec1305991ce1a0303a9a17997edd1e71da6c583b3 /dev-python/apsw
parentgames-strategy/warzone2100: add 4.3.4 (diff)
downloadgentoo-501e948b8361cb84a09fb4efd06f10f277db5775.tar.gz
gentoo-501e948b8361cb84a09fb4efd06f10f277db5775.tar.bz2
gentoo-501e948b8361cb84a09fb4efd06f10f277db5775.zip
dev-python/apsw: Bump to 3.41.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apsw')
-rw-r--r--dev-python/apsw/Manifest1
-rw-r--r--dev-python/apsw/apsw-3.41.2.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/apsw/Manifest b/dev-python/apsw/Manifest
index 1c8fa16a0709..f010388537e4 100644
--- a/dev-python/apsw/Manifest
+++ b/dev-python/apsw/Manifest
@@ -1,2 +1,3 @@
DIST apsw-3.40.1.0.gh.tar.gz 423060 BLAKE2B 7ac1a587ab93b4cd6ae20a137f2f1a2e96039209f74c8aa626ea7bf219b1698403fe4c8365662e8b896a56024b45b36a80df5f506d6a813dea920add202479cd SHA512 243d47efc7407c4f3bad92d1bf4044fe4a53d913b86e1821c7d1c3711348bf25b2a339a68d18075f99c0899766085c2f2b93a303f8298c115463224ad46f99f1
DIST apsw-3.41.0.0.gh.tar.gz 837111 BLAKE2B f3374dae906148d7553c9c67c7e1f91acfc5124d525aa37728f81ce39c33368ae387a555dc2c50d2117a29e35c925a968968cdf22fd18477d00a877efcfef876 SHA512 f5ee663e15f54fc8f3d1fe6435be6470f9399271d2f746b8e624a98b1ae8b5fcaa0152ddae9e99d8ab2876388e42348f8e9ba8773f34e7042a72467d794c108b
+DIST apsw-3.41.2.0.gh.tar.gz 871995 BLAKE2B 3d6959133cbfe8914eaadb46543a3a65db24b97aef362eb43e90448be34467a2a9e0f651ff67a9b0ce02df2c6eefa5b5e1c599547e72713e2ddbd1ec6c4f558b SHA512 292ea5a84f406fccb3ba5bf229a38d9c35a32f342b7e1065f08b2758c1d0d9b6517d37c32ce625f9e21cc55339eb2eea35da26a0f17d79a1fc58e1d6b08a8570
diff --git a/dev-python/apsw/apsw-3.41.2.0.ebuild b/dev-python/apsw/apsw-3.41.2.0.ebuild
new file mode 100644
index 000000000000..029ab66ba97a
--- /dev/null
+++ b/dev-python/apsw/apsw-3.41.2.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="APSW - Another Python SQLite Wrapper"
+HOMEPAGE="
+ https://github.com/rogerbinns/apsw/
+ https://pypi.org/project/apsw/
+"
+SRC_URI="
+ https://github.com/rogerbinns/apsw/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ZLIB"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="
+ >=dev-db/sqlite-${PV%.*}:3
+"
+RDEPEND="
+ ${DEPEND}
+"
+
+src_configure() {
+ cat >> setup.cfg <<-EOF || die
+ [build_ext]
+ enable=load_extension
+ use_system_sqlite_config=True
+ EOF
+}
+
+python_test() {
+ esetup.py build_test_extension
+ cd "${T}" || die
+ "${EPYTHON}" -m apsw.tests -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/. )
+ distutils-r1_python_install_all
+}