summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-03-09 19:48:09 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-03-09 20:26:00 +0200
commit39b02240a39fa7fdf94e2285ee9c91bdb7eb799f (patch)
treee996fdfbafb1f35614305c341b4933a31bbadc49 /dev-python/asn1crypto
parentdev-python/boto3: add 1.21.15 (diff)
downloadgentoo-39b02240a39fa7fdf94e2285ee9c91bdb7eb799f.tar.gz
gentoo-39b02240a39fa7fdf94e2285ee9c91bdb7eb799f.tar.bz2
gentoo-39b02240a39fa7fdf94e2285ee9c91bdb7eb799f.zip
dev-python/asn1crypto: add 1.5.0
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/asn1crypto')
-rw-r--r--dev-python/asn1crypto/Manifest1
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.5.0.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/Manifest b/dev-python/asn1crypto/Manifest
index e47867e63666..258547d0420d 100644
--- a/dev-python/asn1crypto/Manifest
+++ b/dev-python/asn1crypto/Manifest
@@ -1 +1,2 @@
DIST asn1crypto-1.4.0.gh.tar.gz 672812 BLAKE2B 7545d424c244c04c2639df45e0bb56c50de95d0a7ee1e56933720dd7215c2be2608ac7889e2e901785592592e9ac6cb116fff3cd00536903c392a9e3912fc08a SHA512 989e4e0650252c29477d71263549b99f2c51c87f0768c20264b3de65f32edd8e7922e8af23bb1a7e29567a4ad8c4c5d596cdf7db3c766352c7f19d4f93361cd0
+DIST asn1crypto-1.5.0.gh.tar.gz 686107 BLAKE2B 9a21c50b5b2c0504178efa0cd5389d004595020ee87b7a5c8e469f9c2de8eb75817d507cd2f8fd0515087d63ca8b135f4c3b85db418997ccbff286e2551c0a1c SHA512 2045ae0ddf777c7a6bc6ba946f457e6a2561d4ebe8fa0ad5b6663af345c6a232a4fd1751dcad6e3c4a99b56c06148801485fb81f1a48e04b1b711dda9d6d0e54
diff --git a/dev-python/asn1crypto/asn1crypto-1.5.0.ebuild b/dev-python/asn1crypto/asn1crypto-1.5.0.ebuild
new file mode 100644
index 000000000000..6d42655df619
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-1.5.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest