summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-03-15 18:58:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-03-15 19:24:32 +0100
commitadf259af1c6be3df15e88e029f7f6f25f237ef08 (patch)
treeabcdd96588a8169957820d1bff187356bf337e22 /dev-python/asn1crypto
parentdev-python/pyzbar: Bump to 0.1.9 (diff)
downloadgentoo-adf259af1c6be3df15e88e029f7f6f25f237ef08.tar.gz
gentoo-adf259af1c6be3df15e88e029f7f6f25f237ef08.tar.bz2
gentoo-adf259af1c6be3df15e88e029f7f6f25f237ef08.zip
dev-python/asn1crypto: Bump to 1.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/asn1crypto')
-rw-r--r--dev-python/asn1crypto/Manifest1
-rw-r--r--dev-python/asn1crypto/asn1crypto-1.5.1.ebuild21
2 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/asn1crypto/Manifest b/dev-python/asn1crypto/Manifest
index 258547d0420d..d25b7ec9e0bd 100644
--- a/dev-python/asn1crypto/Manifest
+++ b/dev-python/asn1crypto/Manifest
@@ -1,2 +1,3 @@
DIST asn1crypto-1.4.0.gh.tar.gz 672812 BLAKE2B 7545d424c244c04c2639df45e0bb56c50de95d0a7ee1e56933720dd7215c2be2608ac7889e2e901785592592e9ac6cb116fff3cd00536903c392a9e3912fc08a SHA512 989e4e0650252c29477d71263549b99f2c51c87f0768c20264b3de65f32edd8e7922e8af23bb1a7e29567a4ad8c4c5d596cdf7db3c766352c7f19d4f93361cd0
DIST asn1crypto-1.5.0.gh.tar.gz 686107 BLAKE2B 9a21c50b5b2c0504178efa0cd5389d004595020ee87b7a5c8e469f9c2de8eb75817d507cd2f8fd0515087d63ca8b135f4c3b85db418997ccbff286e2551c0a1c SHA512 2045ae0ddf777c7a6bc6ba946f457e6a2561d4ebe8fa0ad5b6663af345c6a232a4fd1751dcad6e3c4a99b56c06148801485fb81f1a48e04b1b711dda9d6d0e54
+DIST asn1crypto-1.5.1.gh.tar.gz 686175 BLAKE2B 1e308ac17c36daaa9ca69fc48ccf0465e540b07d96c1a3e6977844994950e2c75061d7b88525b7e46b61e5c725ac4505ada8757d51ac67c72f11f86917fca54b SHA512 1bcb93d82a2602e3b5c66a180f5d16cd3a9731d86d89fbd44c1e23d735e708e9bf9bb6cbabc2a5d60619f51a7c38dfb1f7ed63820f422ccf42800a39f4637626
diff --git a/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild b/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild
new file mode 100644
index 000000000000..081b08e25a79
--- /dev/null
+++ b/dev-python/asn1crypto/asn1crypto-1.5.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python ASN.1 library with a focus on performance and a pythonic API"
+HOMEPAGE="https://github.com/wbond/asn1crypto/ https://pypi.org/project/asn1crypto/"
+# pypi tarball does not have tests
+SRC_URI="https://github.com/wbond/asn1crypto/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-cygwin ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+distutils_enable_tests unittest