summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-16 17:30:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-16 17:30:15 +0100
commita7df665db10c4197d787013f31d4915496bf7e0b (patch)
tree1491521afe9b40f7a51018ee44da9f9be6b50a61 /dev-python/async-lru
parentdev-python/asteval: Remove old (diff)
downloadgentoo-a7df665db10c4197d787013f31d4915496bf7e0b.tar.gz
gentoo-a7df665db10c4197d787013f31d4915496bf7e0b.tar.bz2
gentoo-a7df665db10c4197d787013f31d4915496bf7e0b.zip
dev-python/async-lru: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/async-lru')
-rw-r--r--dev-python/async-lru/Manifest3
-rw-r--r--dev-python/async-lru/async-lru-1.0.3.ebuild39
-rw-r--r--dev-python/async-lru/async-lru-2.0.0.ebuild42
-rw-r--r--dev-python/async-lru/async-lru-2.0.1.ebuild43
4 files changed, 0 insertions, 127 deletions
diff --git a/dev-python/async-lru/Manifest b/dev-python/async-lru/Manifest
index 7d8ff68a5075..3c984ce3739c 100644
--- a/dev-python/async-lru/Manifest
+++ b/dev-python/async-lru/Manifest
@@ -1,4 +1 @@
-DIST async-lru-1.0.3.gh.tar.gz 10709 BLAKE2B 437880c419d0d8df5c790ff9b93d0b608dacba1847fc0974d35f89ff97bdd07589edc5371c729889791cb05cd8ec684764ecedc6d0d36b05ee930f885570095c SHA512 530c6e1f7a1ecc8a78cac927ccb9dfc2e394498a6ed3f54e73e4e9af48ef26ddeaad56a056a50b3c3974324af69b393cd94b1f4d20e3a2944b217c03a6bd6394
-DIST async-lru-2.0.0.gh.tar.gz 11119 BLAKE2B 7bfc174ec68ce8a3ad7de94c6eb555aa53be5561c7376bf8149e91f9d8f08361f4b51ba45cecaa77cc89c5c7fc4a225f71fd56878cf64647f7cc82a06ec76b02 SHA512 dbbd4f63d488bde8d4e15b205bca2850c8992d67491c5c0d2c245ed2bc1005df523f837c736db96b6cdcad22c9cf409111040e9d3a86a38c5b627aa256a6b5a6
-DIST async-lru-2.0.1.gh.tar.gz 11150 BLAKE2B 034da5aee6c7d7177c9c878d22617aa0aecd143271319fbe5c0fdd346febef73b4d4e3b2293dbf6a522474cb95cde574a0250bde93c4749f1b4c93bb1db449a5 SHA512 8bb4698320534d722fe1978f0d3402c886dd391caa974afc2be70eb323855b37b1e5b5936bea14b118b78d5c18363306996530014a0ea010150ff464a6531b68
DIST async-lru-2.0.2.gh.tar.gz 11040 BLAKE2B dc1dfb12189cdcf8283b77d2b451031e691b1fd833e34df450ce87fd496b57d5a04a7f6ca183bb07d7e820f68cafade44237e626e3694d732df40dbf38f22baf SHA512 ce1f9f241200dd05d44196f06e688c2852fbe1bb2356f5611dbc9ac8109e1313ecdcccbba70944e936aa6bc59864d9cc339daaa58416ec0850f3b2afd17123d3
diff --git a/dev-python/async-lru/async-lru-1.0.3.ebuild b/dev-python/async-lru/async-lru-1.0.3.ebuild
deleted file mode 100644
index 2cbc875de31d..000000000000
--- a/dev-python/async-lru/async-lru-1.0.3.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple lru_cache for asyncio"
-HOMEPAGE="
- https://github.com/aio-libs/async-lru/
- https://pypi.org/project/async-lru/
-"
-SRC_URI="
- https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-BDEPEND="
- test? (
- >=dev-python/pytest-6.2.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e 's:--cache-clear::' \
- -e 's:--no-cov-on-fail --cov=async_lru --cov-report=term --cov-report=html::' \
- -i setup.cfg || die
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/async-lru/async-lru-2.0.0.ebuild b/dev-python/async-lru/async-lru-2.0.0.ebuild
deleted file mode 100644
index ad601a9411d7..000000000000
--- a/dev-python/async-lru/async-lru-2.0.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple lru_cache for asyncio"
-HOMEPAGE="
- https://github.com/aio-libs/async-lru/
- https://pypi.org/project/async-lru/
-"
-SRC_URI="
- https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/pytest-6.2.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e 's:--cache-clear::' \
- -e 's:--no-cov-on-fail --cov=async_lru --cov-report=term --cov-report=html::' \
- -i setup.cfg || die
-
- distutils-r1_src_prepare
-}
diff --git a/dev-python/async-lru/async-lru-2.0.1.ebuild b/dev-python/async-lru/async-lru-2.0.1.ebuild
deleted file mode 100644
index 2ca31dbeb7f1..000000000000
--- a/dev-python/async-lru/async-lru-2.0.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Simple lru_cache for asyncio"
-HOMEPAGE="
- https://github.com/aio-libs/async-lru/
- https://pypi.org/project/async-lru/
-"
-SRC_URI="
- https://github.com/aio-libs/async-lru/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-RDEPEND="
- >=dev-python/typing-extensions-4.0.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- >=dev-python/pytest-6.2.4[${PYTHON_USEDEP}]
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed -e 's:--cache-clear::' \
- -e 's:--no-cov-on-fail --cov=async_lru --cov-report=term --cov-report=html::' \
- -i setup.cfg || die
-
- distutils-r1_src_prepare
-}