summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-16 11:32:13 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-16 12:31:40 +0100
commit98e703df272ba2b7e590e3e6d4da21df67d2c5e0 (patch)
tree7085b9f409d12d544e31a1a2c571ea7a07964f3d /dev-python/autopep8
parentdev-util/stripe-mock: Bump to 0.148.0 (diff)
downloadgentoo-98e703df272ba2b7e590e3e6d4da21df67d2c5e0.tar.gz
gentoo-98e703df272ba2b7e590e3e6d4da21df67d2c5e0.tar.bz2
gentoo-98e703df272ba2b7e590e3e6d4da21df67d2c5e0.zip
dev-python/autopep8: Bump to 2.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/autopep8')
-rw-r--r--dev-python/autopep8/Manifest1
-rw-r--r--dev-python/autopep8/autopep8-2.0.1.ebuild47
-rw-r--r--dev-python/autopep8/autopep8-9999.ebuild15
3 files changed, 52 insertions, 11 deletions
diff --git a/dev-python/autopep8/Manifest b/dev-python/autopep8/Manifest
index 552e26e681d5..97b274a5f387 100644
--- a/dev-python/autopep8/Manifest
+++ b/dev-python/autopep8/Manifest
@@ -1 +1,2 @@
DIST autopep8-2.0.0.tar.gz 117507 BLAKE2B 8722b19454f47d0b960e3cc0e18ff3d6150ead009630047ecd1ce9001ea6f6d68595f80d7ad1087bddd2993e95d0634d63495b1d43dee095d114535bf632d1bf SHA512 883b79f7011a374a2ef88073a45748268a20449a3bc8da519c036c71700352dd8c4accc60fcb592f1a53ceac06984fcbe6ede8a272bc718c2b79873be5f35dd8
+DIST autopep8-2.0.1.tar.gz 115905 BLAKE2B 9dde8d702a0b21fb1457e08120dca805e2b46e3e5284e5d98932ff93afc4c0ac8dbc60215f35b64d4a308d6748df1411c2979d8fa1f4949b1dbe213bf19de9dc SHA512 cc0e8e5b7228ba9b37adaa3b2689a5e1ad04eb84366c5300d7a220b1593a64e4f1dc332750f8ca53935dec6a3ea1d07cae5615373e44da357a980d9763bbc3f1
diff --git a/dev-python/autopep8/autopep8-2.0.1.ebuild b/dev-python/autopep8/autopep8-2.0.1.ebuild
new file mode 100644
index 000000000000..e54d2fef8e1a
--- /dev/null
+++ b/dev-python/autopep8/autopep8-2.0.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Automatically formats Python code to conform to the PEP 8 style guide"
+HOMEPAGE="
+ https://github.com/hhatto/autopep8/
+ https://pypi.org/project/autopep8/
+"
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/hhatto/${PN}.git"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND="
+ >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=()
+
+ [[ ${EPYTHON} == python3.11 ]] && EPYTEST_DESELECT+=(
+ # fails due to deprecation warnings
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes
+ test/test_autopep8.py::CommandLineTests::test_in_place_no_modifications_no_writes_with_empty_file
+ )
+
+ epytest
+}
diff --git a/dev-python/autopep8/autopep8-9999.ebuild b/dev-python/autopep8/autopep8-9999.ebuild
index b201d023a72a..ed142ae0e692 100644
--- a/dev-python/autopep8/autopep8-9999.ebuild
+++ b/dev-python/autopep8/autopep8-9999.ebuild
@@ -26,17 +26,10 @@ LICENSE="MIT"
SLOT="0"
RDEPEND="
- >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
- dev-python/tomli[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.10[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
"
distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # test require in source build
- test/test_autopep8.py::SystemTests::test_e101_skip_innocuous
-)
-
-PATCHES=(
- "${FILESDIR}"/autopep8-1.6.0-lib2to3-deprecation-pytest.patch
-)