summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-12-17 08:07:07 +0100
committerMichał Górny <mgorny@gentoo.org>2022-12-17 08:07:07 +0100
commit1cabbe2b41c9853bdc795596e4a13f2255a97a63 (patch)
treea9fc4498f07ff491833abcd7cc0763a7381849b2 /dev-python/aws-xray-sdk-python
parentdev-python/sqlalchemy: Remove old (diff)
downloadgentoo-1cabbe2b41c9853bdc795596e4a13f2255a97a63.tar.gz
gentoo-1cabbe2b41c9853bdc795596e4a13f2255a97a63.tar.bz2
gentoo-1cabbe2b41c9853bdc795596e4a13f2255a97a63.zip
dev-python/aws-xray-sdk-python: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aws-xray-sdk-python')
-rw-r--r--dev-python/aws-xray-sdk-python/Manifest1
-rw-r--r--dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild84
2 files changed, 0 insertions, 85 deletions
diff --git a/dev-python/aws-xray-sdk-python/Manifest b/dev-python/aws-xray-sdk-python/Manifest
index afe5cd925af2..31d38d10493a 100644
--- a/dev-python/aws-xray-sdk-python/Manifest
+++ b/dev-python/aws-xray-sdk-python/Manifest
@@ -1,2 +1 @@
-DIST aws-xray-sdk-python-2.10.0.gh.tar.gz 270819 BLAKE2B caed5f5b92bdc25e0006663838549c9e9a85474829cce03f612ef4b9a36fce38460606e000c65bb140f7250225426bece2e8bc624a430bdfdcd4fc8808842aac SHA512 f5b4d08f5876cab2e833a763b1da52b6de1e3ca2c746b234a1b013f674155ec31686a6710225e411458f27ca096f68ee6413c8d1c360d5a326f1be94287d09b7
DIST aws-xray-sdk-python-2.11.0.gh.tar.gz 275430 BLAKE2B 1c1d3b56629dbd822b4f9fcb1e7ba5b43fbbff55fbe7ac02d75e0bb50629c4a0e5baed2b4c14c4c8a7775d60da5b285f96bca68b68b64ddf03aeec0c6094c74c SHA512 62035db955ce3d60e6d75088b7255dec83b21b4fd02353146b34bc48bdacff805b711b5caaca7adbbb5c5a3632a97910907d04681f36c198c99fbb4ef1cc4f85
diff --git a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild b/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild
deleted file mode 100644
index 6d0cb2cf98e6..000000000000
--- a/dev-python/aws-xray-sdk-python/aws-xray-sdk-python-2.10.0.ebuild
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="AWS X-Ray SDK for Python"
-HOMEPAGE="
- https://github.com/aws/aws-xray-sdk-python/
- https://pypi.org/project/aws-xray-sdk/
-"
-SRC_URI="
- https://github.com/aws/aws-xray-sdk-python/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc64 ~riscv x86 ~amd64-linux ~x86-linux"
-
-RDEPEND="
- >=dev-python/botocore-1.12.122[${PYTHON_USEDEP}]
- dev-python/wrapt[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/bottle[${PYTHON_USEDEP}]
- <dev-python/flask-sqlalchemy-3[${PYTHON_USEDEP}]
- dev-python/flask[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- >=dev-python/sqlalchemy-1.4[${PYTHON_USEDEP}]
- dev-python/webtest[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}/${PN}-2.8.0-fix-py3.10-loops.patch"
-)
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x DJANGO_SETTINGS_MODULE=tests.ext.django.app.settings
- local -x AWS_SECRET_ACCESS_KEY=fake_key
- local -x AWS_ACCESS_KEY_ID=fake_id
-
- local EPYTEST_DESELECT=(
- # Internet access
- tests/test_patcher.py::test_external_file
- tests/test_patcher.py::test_external_module
- tests/test_patcher.py::test_external_submodules_full
- tests/test_patcher.py::test_external_submodules_ignores_file
- tests/test_patcher.py::test_external_submodules_ignores_module
- # benchmark
- tests/test_local_sampling_benchmark.py
- # Fails, probably because above is ignored
- tests/test_async_local_storage.py::test_localstorage_isolation
- tests/test_async_recorder.py::test_capture
- tests/test_async_recorder.py::test_concurrent_calls
- tests/test_async_recorder.py::test_async_context_managers
- )
- local EPYTEST_IGNORE=(
- # unpackaged deps
- tests/ext/aiobotocore
- tests/ext/pg8000
- tests/ext/psycopg2
- tests/ext/pymysql
- tests/ext/pynamodb
- tests/ext/sqlalchemy_core/test_postgres.py
- tests/ext/django/test_db.py
- # Internet access
- tests/ext/httplib
- tests/ext/requests
- # requires old package vesions
- tests/ext/django
- tests/ext/aiohttp
- )
-
- epytest -p no:django
-}