summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2023-01-27 15:20:05 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2023-01-27 15:20:05 +0200
commitd152810e555e82e158af2d814fbf80a0d61a31a7 (patch)
treed96284485e45a6f8c02cb62c1185aa43911a1325 /dev-python/beagle
parentdev-python/django_polymorphic: enable py3.11 (diff)
downloadgentoo-d152810e555e82e158af2d814fbf80a0d61a31a7.tar.gz
gentoo-d152810e555e82e158af2d814fbf80a0d61a31a7.tar.bz2
gentoo-d152810e555e82e158af2d814fbf80a0d61a31a7.zip
dev-python/beagle: USE PEP517, EAPI=8
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/beagle')
-rw-r--r--dev-python/beagle/beagle-0.3.0-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/beagle/beagle-0.3.0-r1.ebuild b/dev-python/beagle/beagle-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..f931b80dfbbf
--- /dev/null
+++ b/dev-python/beagle/beagle-0.3.0-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+inherit distutils-r1
+
+DESCRIPTION="Command line client for Hound, the code search tool"
+HOMEPAGE="https://beagle-hound.readthedocs.io/en/latest/
+ https://github.com/beaglecli/beagle"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# setuptools is needed as rdepend, https://github.com/beaglecli/beagle/pull/14
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ >=dev-python/cliff-2.11.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.18.4[${PYTHON_USEDEP}]
+"
+BDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]"