summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-08 12:54:48 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-08 12:59:36 +0200
commita57b744ff4aeaf9e06c089d7fbf82cd8eed602d5 (patch)
tree692b6cc12f3c4ff1a0a59a160255ee612a568a20 /dev-python/beautifulsoup4
parentsys-apps/colorized-logs: Migrate to cmake.eclass (diff)
downloadgentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.tar.gz
gentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.tar.bz2
gentoo-a57b744ff4aeaf9e06c089d7fbf82cd8eed602d5.zip
Rename dev-python/{beautifulsoup → beautifulsoup4}
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/beautifulsoup4')
-rw-r--r--dev-python/beautifulsoup4/Manifest2
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild24
-rw-r--r--dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild32
-rw-r--r--dev-python/beautifulsoup4/metadata.xml20
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/beautifulsoup4/Manifest b/dev-python/beautifulsoup4/Manifest
new file mode 100644
index 000000000000..4dede2d8d2dd
--- /dev/null
+++ b/dev-python/beautifulsoup4/Manifest
@@ -0,0 +1,2 @@
+DIST beautifulsoup4-4.10.0.tar.gz 399890 BLAKE2B 61f044064a81e94b64a72fd49cca164faa05442bc76f897c8a7fa4481acca039bcb9e4f7a1853a7155504fa25e56c518806d8af016369bc37316ecb95b59d7d3 SHA512 92be99ed0fd479b86519395143516e28f7b80f54a8251223d6e7b88dc98f8dfca9585079f5f1d89bfe68f577de3dff433711642486303203f46bc76754959a18
+DIST beautifulsoup4-4.9.3.tar.gz 376031 BLAKE2B fbe2139f288eee978c3f665c7640f66c6c51b857a186f6a8ace02b36effa1552f1cbea9e3744e0a46a65a06e6cdbd9203832e0ecd86b61406b933f9bd83d37b8 SHA512 e3cb6258bd7c51f12128fa8ee5948fb3566163ae233fac2dda21bab7772ab8dbb384d920b0ea138ef9921307b48f89cee3a9bf6111dfc8903d917ee7af365f34
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
new file mode 100644
index 000000000000..78187c60a289
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.10.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx doc/source
diff --git a/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
new file mode 100644
index 000000000000..589f96740cb5
--- /dev/null
+++ b/dev-python/beautifulsoup4/beautifulsoup4-4.9.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Pythonic idioms for iterating, searching, and modifying an HTML/XML parse tree"
+HOMEPAGE="https://www.crummy.com/software/BeautifulSoup/bs4/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="4"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/soupsieve[${PYTHON_USEDEP}]
+ dev-python/html5lib[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ <dev-python/setuptools-58[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests nose
+distutils_enable_sphinx doc/source
+
+python_test() {
+ nosetests --verbose -w "${BUILD_DIR}"/lib || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/beautifulsoup4/metadata.xml b/dev-python/beautifulsoup4/metadata.xml
new file mode 100644
index 000000000000..227205f32598
--- /dev/null
+++ b/dev-python/beautifulsoup4/metadata.xml
@@ -0,0 +1,20 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription lang="en">
+ Beautiful Soup is a Python HTML/XML parser designed for quick
+ turnaround projects like screen-scraping. Two features make it
+ powerful: it won't choke if you give it bad markup and it provides a
+ few simple methods and Pythonic idioms for navigating and searching
+ a parse tree: a toolkit for dissecting a document and extracting
+ what you need.
+ </longdescription>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="pypi">beautifulsoup4</remote-id>
+ </upstream>
+</pkgmetadata>