summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-04-10 14:57:30 +0200
committerDavid Seifert <soap@gentoo.org>2016-04-10 14:57:48 +0200
commit1850fe6cc0800dff669e879534dcc5e1bcf54176 (patch)
treebff9fb612ea22c9e20b0a86c5b5cb08487b772a6 /dev-python/bibtexparser/bibtexparser-0.6.2.ebuild
parentdev-ruby/ruby-gstreamer: Remove ruby19 (diff)
downloadgentoo-1850fe6cc0800dff669e879534dcc5e1bcf54176.tar.gz
gentoo-1850fe6cc0800dff669e879534dcc5e1bcf54176.tar.bz2
gentoo-1850fe6cc0800dff669e879534dcc5e1bcf54176.zip
dev-python/bibtexparser: New package
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/bibtexparser/bibtexparser-0.6.2.ebuild')
-rw-r--r--dev-python/bibtexparser/bibtexparser-0.6.2.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/bibtexparser/bibtexparser-0.6.2.ebuild b/dev-python/bibtexparser/bibtexparser-0.6.2.ebuild
new file mode 100644
index 000000000000..d57a7a931d70
--- /dev/null
+++ b/dev-python/bibtexparser/bibtexparser-0.6.2.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1 python-r1
+
+DESCRIPTION="A BibTeX parser written in python"
+HOMEPAGE="https://github.com/sciunto-org/python-bibtexparser"
+SRC_URI="https://github.com/sciunto-org/python-bibtexparser/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/python-${P}"
+
+src_test() {
+ python_foreach_impl nosetests
+}