summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-01-04 13:41:25 +0100
committerMichał Górny <mgorny@gentoo.org>2023-01-04 15:11:56 +0100
commit23a99449c007bb9c87025c1f5122dba8d01cee8d (patch)
tree293404b03bfb2a8286cbf62819ae6b1abe54f861 /dev-python/boto3
parentdev-python/botocore: Bump to 1.29.42 (diff)
downloadgentoo-23a99449c007bb9c87025c1f5122dba8d01cee8d.tar.gz
gentoo-23a99449c007bb9c87025c1f5122dba8d01cee8d.tar.bz2
gentoo-23a99449c007bb9c87025c1f5122dba8d01cee8d.zip
dev-python/boto3: Bump to 1.26.42
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.42.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 22a8d2778621..f18c70ce0781 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -1,3 +1,4 @@
DIST boto3-1.26.32.gh.tar.gz 581235 BLAKE2B f8decc1e924ff5f5f98566084a55c36ea10ca38596e0f8398a9d5865e6246290e9e09ff3e95622eacca9f32b6f8119156b2ba5a6ce0135e988fad0bcdb161030 SHA512 73c6f8f1e1d5f12887e880cc651399fbd147c65740090bd09303540dcc902efc6b04605551f055341e84cb8b72cdcb9d8d444263fc0131b8f5013197e67c1fb5
DIST boto3-1.26.37.gh.tar.gz 584822 BLAKE2B 08c08502f3defee6365aa19a55cb5bb6c006ce9685421119d1469f90f35e0aeb49fc11a6c5dd133cdfe1138248c0952338adb7b864010825f6f32f40398c2f4f SHA512 4c73b45cae0ed42f219b77d5b58f26560f3ac660d66eaea0c8452053ed38b4c8cc7ab168062483a52e091f7241623466a473368e0545a9fa07c0ac12d0185e31
DIST boto3-1.26.41.gh.tar.gz 586086 BLAKE2B 8f5fac4e26a8ff34e91ee99ab4f93b6c31174cea7fdb1a7e98c942601324fd4128b4609fb1b28d7daf4139dfc1e0fc75760d64693f33e225cc4180c83867aebb SHA512 d87db9db58315de796750d478d6488815cd37307693305d2c6fd0e5f1d04aef51190fa438d942412def7d0075ebb23d440508415459bd9dda83302d29e7cc646
+DIST boto3-1.26.42.gh.tar.gz 586350 BLAKE2B 2dab3f95a6fd17debb1e77fc24f319d1edbd8d0ae1703c339022bad66cf5443860aad122c466a4087ce0954acfd371e41f957c07c972408e3f698c437952501c SHA512 0d8b4b6226c82ed0496baa3db0ef3d6778931d33ba1367738e22fe11fcf24bcfdbc29a5d67aef61648f5d784cb31d0b3f7472b0d64909c1d2ed544dd95ba7c1a
diff --git a/dev-python/boto3/boto3-1.26.42.ebuild b/dev-python/boto3/boto3-1.26.42.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.42.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}