summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-21 04:07:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-21 05:13:49 +0200
commit3b89f59b173b788b5b4ec6c0a418273e5214e2aa (patch)
tree247f6e84aa5e9bf602b610ffda6720d492029095 /dev-python/boto3
parentdev-python/botocore: Bump to 1.35.2 (diff)
downloadgentoo-3b89f59b173b788b5b4ec6c0a418273e5214e2aa.tar.gz
gentoo-3b89f59b173b788b5b4ec6c0a418273e5214e2aa.tar.bz2
gentoo-3b89f59b173b788b5b4ec6c0a418273e5214e2aa.zip
dev-python/boto3: Bump to 1.35.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.35.2.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c5b0b7cb0820..f2f5e0c40d1c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.34.153.gh.tar.gz 847038 BLAKE2B f29aec887fd57d2bc4b6be125787384438e
DIST boto3-1.34.158.gh.tar.gz 848930 BLAKE2B 5db04b9eee08f5418a595e736f075fbe22b92adada9219e8a8cf2299c723d09e2edf88e5ebb3d09c1613a01e5d0d5c837e9545c6ee3110c430c521da10fa2bde SHA512 03f532e78a1a2b8ec01396f0b7f7bae7059165e35440eda47f4393e99d2a8ded229470cf3269a71c746b8a66dccd8626444f1e429e561df1dc1ec0f6b8653272
DIST boto3-1.35.0.gh.tar.gz 851637 BLAKE2B 485b17616fed53a88280aad92d2e4219d8bcbf469b42cff6113f9596c6b245fad39b403b4fb29ed99b50955baa50940091e9c0f88cc6e350b44c69c4b1df5fdc SHA512 0236748c667ef1baf7484d4808083cb517c19ceae672973ac0cf9ce509a9e4a965c15349876807dc320fc96210ba6c5d16ea66545de19eed33dace058392d85d
DIST boto3-1.35.1.gh.tar.gz 852178 BLAKE2B c1706b6f22fec5046ec0653a87be74113ed8031c1140efa296ce8d4d8d126da65a4dd0ce62413a078a88c4c11739a7e55a86363eca16b10e96e0344d3ad63fd2 SHA512 03a121ae24ec6b5d2a5ed869a2d7ff6cf2078c45abed09bf014dca14575b3612ffecd73e784aab74051364bb211d33871bf4f212cb603e1cbe980cd85d749629
+DIST boto3-1.35.2.gh.tar.gz 852524 BLAKE2B 28a0408e2187952eb8f9f0e37de105007e6c4d0f11358c8ccc5246a8798b24f1472eaa788e3268c9e9fe9888953d6ab323e337e5d4a53179cd4bbd26c1776e89 SHA512 7b25f6ab5b29789e1b90f888f74708ade430e5c9f746346fb4ba0aa15f6ab55d892a9331d4c3e06fab5c683c2e0d7745c8adf10a6a259398f8fb88b1dafe52f1
diff --git a/dev-python/boto3/boto3-1.35.2.ebuild b/dev-python/boto3/boto3-1.35.2.ebuild
new file mode 100644
index 000000000000..8cba6d95740e
--- /dev/null
+++ b/dev-python/boto3/boto3-1.35.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}