summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-02-18 06:24:13 +0100
committerMichał Górny <mgorny@gentoo.org>2023-02-18 08:02:50 +0100
commitb34b5bf742a243259c99d510afedd537f2fb4d76 (patch)
tree5774f24b6cd356ea0b9f0b17cfd58ebff5918af6 /dev-python/boto3
parentdev-python/botocore: Bump to 1.29.74 (diff)
downloadgentoo-b34b5bf742a243259c99d510afedd537f2fb4d76.tar.gz
gentoo-b34b5bf742a243259c99d510afedd537f2fb4d76.tar.bz2
gentoo-b34b5bf742a243259c99d510afedd537f2fb4d76.zip
dev-python/boto3: Bump to 1.26.74
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.26.74.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 92178742ae6c..932f92f50c8d 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.26.70.gh.tar.gz 600798 BLAKE2B b55125e70865f73b8ba5e7945eca6a975f47
DIST boto3-1.26.71.gh.tar.gz 601272 BLAKE2B ca2feb8c8a733033338ae50a7a9bac3779afc233fbd8e55c75a1e9bb87e224c789d22b940b68e1f90405886cceef60f860c33f7d99a64b288a29f8377eaa8815 SHA512 ca4eeaa29f0d025a6e0d7e55680f8c6ca231cd8616a373ca60a84d51f271750b05640b71ea97bebd539e762efe7a714f86e1f3c142620996240df02ef7cfac48
DIST boto3-1.26.72.gh.tar.gz 601919 BLAKE2B 7a0d7e1e2cb2a2085e641127807aa55677c778aee7a86daded4d6c57cf430ae9a610fbce03527911f9c9be775cf5229451668c6e600635e87d5d21690e52e8ad SHA512 859c2a5260805eaf86ca16d94f1b58d7047f1a1c911b9c553c4a2f8a0902e1b5cd96885eed64865f1a8795552744b9f4e39382ebe0c681939ea6e4119a81b474
DIST boto3-1.26.73.gh.tar.gz 602354 BLAKE2B 2a8a617011e0a06dcf488c44863489fd3486650e4b4f349af505571ffa2e3beaa15147a82f22316ed7942e3b9f179e2cbf3249203bfd80dc3ca3a3789966958f SHA512 21ee634438b29d03402f9776f982331806c0dadf7186f28556a9aa0a4e1fb47730c280bc50a4fdf92c50ce683806c979339a7ff4b62e654b8314b26a9b483743
+DIST boto3-1.26.74.gh.tar.gz 602525 BLAKE2B 6d9b397864649ecd9b3f46bcee832c57cdce809545522f3beaf0d2eb98ca1f99e5fcab132f3389a4b2edcd585d9f6759de961b1f83f5912420629b6b03092c36 SHA512 eba11711dbd77988deb1695b954b6eb931b8ad49f96971e221415355de9bd2f3015b5a58be34a7378180f59500f9c15135192ccb97454141dbcaa664f0183627
diff --git a/dev-python/boto3/boto3-1.26.74.ebuild b/dev-python/boto3/boto3-1.26.74.ebuild
new file mode 100644
index 000000000000..9523f65d5fb9
--- /dev/null
+++ b/dev-python/boto3/boto3-1.26.74.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}