summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-07-14 07:07:35 +0200
committerMichał Górny <mgorny@gentoo.org>2022-07-14 07:58:14 +0200
commitcc0bd82ca77c83e7999f7de73c95952e8bd2545c (patch)
tree79f40cae824b1268dac360e7209e4b0c7a084a61 /dev-python/boto3
parentdev-python/botocore: Bump to 1.27.29 (diff)
downloadgentoo-cc0bd82ca77c83e7999f7de73c95952e8bd2545c.tar.gz
gentoo-cc0bd82ca77c83e7999f7de73c95952e8bd2545c.tar.bz2
gentoo-cc0bd82ca77c83e7999f7de73c95952e8bd2545c.zip
dev-python/boto3: Bump to 1.24.29
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.24.29.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 6cf1c826cc44..8244ecc5a091 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.24.22.gh.tar.gz 513301 BLAKE2B 1b71d128cc8f8224fd1ef521988e6b5e9415
DIST boto3-1.24.26.gh.tar.gz 515531 BLAKE2B 34f99c4dd224731e07c2f0b175d6d172661ce454a7af16be6856053af1bfac69b7f56ada5b154fb625fe2ba1fb22fbe34b5150c550890e46a923b48f2466b06b SHA512 a3980ec79abd5e2656d7d02b36dff6b8c2acb67033eff134d96dccbb9d8bbc2d711698b87d08d537256fad7e3b3cd7af008018ef567b12d63ef0fc871a8f3b3e
DIST boto3-1.24.27.gh.tar.gz 516237 BLAKE2B 968d48e9f1bf888df5dfc2ebb2d926d918121f96246e8d36ff872e93e347db3d97db42304e148cd21845bc3904977e0000a0e846bb104990cee23343c5995776 SHA512 3ff77f52a5236b12a7344ee9279cbfd53d6847f5afd980820f46971e62ebfa0f2639634c23cd962dfd087af1176596484dbedda6dee3674816a7a569f528caf5
DIST boto3-1.24.28.gh.tar.gz 516274 BLAKE2B 846de56cdd94cb63f855086b051bf8a282cde2dcfb7e581cd35bbe684f71aec3a8c8c451163814f66d7935a8947da4573b9283de8a24a4b1d6b543d7bf5a9323 SHA512 135ffb89fd008d41eb0054b4d746b32f2861520573604714240ccf15d6a2563e3a03179daa13bf153e047e0239ffa1c1884a0f4ee71cf5ca595c5f1ddc521477
+DIST boto3-1.24.29.gh.tar.gz 516486 BLAKE2B 0850ca719fe367fc25ae96fae20a341e5f95d30dc47c7b4176d14516202f54036ff0195520c314c24ee09db8a00a880ab4c8d4146ff4c6570aa56c055bf64dd2 SHA512 9d286d25ab9093778b4027c43d0909630b9b8685fb92b498bcca71ab7ca0406985b7a117e74cf41e3f13923eec3152d6b8142c92b398f3244b4fc78649d5fdd0
diff --git a/dev-python/boto3/boto3-1.24.29.ebuild b/dev-python/boto3/boto3-1.24.29.ebuild
new file mode 100644
index 000000000000..6edcc751d54b
--- /dev/null
+++ b/dev-python/boto3/boto3-1.24.29.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/boto3"
+ inherit git-r3
+ BOTOCORE_PV=${PV}
+else
+ SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+ # botocore is x.(y+3).z
+ BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) + 3)).$(ver_cut 3-)"
+fi
+
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.6.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}