summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-10 04:25:37 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-10 05:02:25 +0100
commit10c4a5ca422a1ed4d27aea0d501d03af717081be (patch)
tree5d29f12309d9cb2da1234457c0f5811e7788fe84 /dev-python/botocore
parentnet-firewall/nftables: add commentary re pkg_preinst check (diff)
downloadgentoo-10c4a5ca422a1ed4d27aea0d501d03af717081be.tar.gz
gentoo-10c4a5ca422a1ed4d27aea0d501d03af717081be.tar.bz2
gentoo-10c4a5ca422a1ed4d27aea0d501d03af717081be.zip
dev-python/botocore: Bump to 1.29.88
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.29.88.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 541e3af856ee..506befe29b70 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,3 +4,4 @@ DIST botocore-1.29.84.gh.tar.gz 11220100 BLAKE2B 588efd08ec38eee7e319ea6e1d41af3
DIST botocore-1.29.85.gh.tar.gz 11218800 BLAKE2B 801e86c9ce18e77b2e4c6c004ed1015369bf8b86ca3dca990865856e979a88dc37e9ce51d8bcab86375f152f44f2727ac1d1ced00fac6da1ba4eac348096ebb2 SHA512 5424e26ddab6b441bfdda1195aad4beb4d01fd976d8640a7707e3e8bc52347816937deff9d7f3ab4aba1704d192738eb5c26a46825efba854dcde7bfdc25a4dd
DIST botocore-1.29.86.gh.tar.gz 11222402 BLAKE2B ceefb618f7156f93bd5a1ccb9addaec225e049922edc6120d34047805fe878a7fb89ee668d966f70e20c0935c0e5bf5f3085dadafebd0bf9f14a873996900740 SHA512 c7846133c86f470ffbc2a189776da5cb86a52ae46441d4abb21a94100383e96ecb50bda9702dcd25ba34fe9421d1f98b8a0b427a87c92d3d18168d306ae4b37d
DIST botocore-1.29.87.gh.tar.gz 11221589 BLAKE2B c60ce2b4d58fa660aebc143f63848d871b2c0e9ad9ce234af3e23e7fc3eef64cc59186d687b844f1c767e569c263500cbb2ec1187bd14fb594eae28e3ed8e219 SHA512 2505f0c397257fb054c5a8808cbe807c2aa86015b71400b4ee7dafecddcef197ab89399df32eb8afc4761974490d65ae3524ee3b0ce7c1cdd9fa33bc1cdb95c4
+DIST botocore-1.29.88.gh.tar.gz 11227872 BLAKE2B 1fd9bf0f147ac87c92723d23b8bcefc8c22261932081aa4530b72de8b96ef964df293100a61940e2adb088f3b6ced4a64758f3c36dbf598676949fe84115083b SHA512 d71f2f7f453ecae000491acef22da701d12e0296154b3ba81cbc0821e9266f6e95e5adefbf94fdf98333775a03d7a6d255f28963c54278f22c5c888d15a291ef
diff --git a/dev-python/botocore/botocore-1.29.88.ebuild b/dev-python/botocore/botocore-1.29.88.ebuild
new file mode 100644
index 000000000000..0f4daaa48e81
--- /dev/null
+++ b/dev-python/botocore/botocore-1.29.88.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}