summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-03-05 11:01:08 +0100
committerMichał Górny <mgorny@gentoo.org>2021-03-05 11:13:56 +0100
commitf35bb062513da529eccc971da3834718293538c1 (patch)
tree30fa4514f734f0312f4bb36b726914e847fb6e06 /dev-python/botocore
parentdev-python/setuptools_scm: Bump to 5.0.2 (diff)
downloadgentoo-f35bb062513da529eccc971da3834718293538c1.tar.gz
gentoo-f35bb062513da529eccc971da3834718293538c1.tar.bz2
gentoo-f35bb062513da529eccc971da3834718293538c1.zip
dev-python/botocore: Bump to 1.20.21
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.21.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 3bf66ae00d80..74e94f753d16 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -4,4 +4,5 @@ DIST botocore-1.20.17.tar.gz 7483893 BLAKE2B 5a9ea5c1d3bc5caa91ea939943d86236d58
DIST botocore-1.20.18.tar.gz 7485852 BLAKE2B df22d0c74796ddc5c7046803039423e31784a2221556a0cb224f0a006870bb4406cf3e576fac1cc65457da0267dbed92159d98d4198c3beef1b995ef7565f06b SHA512 e1881ca20ffc0b3eaf59635a321f0191775b4c62f4aed4d8ada54dee6066ba85fa1af00bea00949ccb245dce4e1279eb1d120237da097420d95e1c3c95c50d6f
DIST botocore-1.20.19.tar.gz 7479977 BLAKE2B 4193cb9975dcde134450968ffcf4cc07b7aece4bbd0d8306483f24eaba63c891cb88d0af640f602b03eb400e5815eb977fca0da927dae0eec82f2922e6c185da SHA512 f4d4ffb88edfb95a13b637c928701966d7903bf50c493926674d8c1c0e6004fa6ec2d9b63402fca5829af3d381ad04221c4154a08e2a0cab065110ab65d44fc1
DIST botocore-1.20.20.tar.gz 7484162 BLAKE2B c9b14936ca8d59070cc99ec56fb7124c2c162f8b3473e3049f57218e41df8bc0bf20172bd65067d504e6317c917573e16d456169564d93dd969e69e87944fdb3 SHA512 aff520c93bea5b600d1c0decd20d49208b2dbf7113f435a633b4b4c68dd0dc46f04079c4e38132d03e5f9aed7a124bcdaaae55ed0126c002acd30954e9609352
+DIST botocore-1.20.21.tar.gz 7489798 BLAKE2B edaea4e14515e5ce5d1a84dcc466f9cc2720f6cf996d61b1ee9fbdb4164849fd3f22fb7321e007b02b7348e6134a20623be4768875de7f7f811e7ea4591197cf SHA512 41086b8f8dac26db5ffdc8d60969f5c2accc756535323d645e44456bdf6af71929211e31e3d73b6fb3ec0367752f8646dbbed2abc0f147b4b34ad462ecd86c48
DIST botocore-1.20.7.tar.gz 7458254 BLAKE2B 8b9a1edda73e2564d3a3d67c6b3542d1ec9372403cb4d88396e58dfbcb5987821f278f2757e079e1ab32e03243ed3a6d1023ecc591b965512b3af5e2d43ea7b0 SHA512 9b023a31be866a50b94017a28aca40b5fe2e720959c928a3fd93db96041f3886049717f50461222a09572c0c56c5961a4614b80e400e4fa6d8b3ff4b4ab681df
diff --git a/dev-python/botocore/botocore-1.20.21.ebuild b/dev-python/botocore/botocore-1.20.21.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.21.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}