summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-08-26 09:15:13 +0200
committerMichał Górny <mgorny@gentoo.org>2021-08-26 09:57:57 +0200
commit2ec4c68951e98b39be7d19670213ec3092275a67 (patch)
treedbaa8bae1e68215f630ac3c5b846b443cc78a1e3 /dev-python/cfgv
parentdev-python/cx_Freeze: add missing dependency to virtual/libcrypt (diff)
downloadgentoo-2ec4c68951e98b39be7d19670213ec3092275a67.tar.gz
gentoo-2ec4c68951e98b39be7d19670213ec3092275a67.tar.bz2
gentoo-2ec4c68951e98b39be7d19670213ec3092275a67.zip
dev-python/cfgv: Bump to 3.3.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/cfgv')
-rw-r--r--dev-python/cfgv/Manifest1
-rw-r--r--dev-python/cfgv/cfgv-3.3.1.ebuild17
2 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/cfgv/Manifest b/dev-python/cfgv/Manifest
index 719425bd2526..978dad04fd1a 100644
--- a/dev-python/cfgv/Manifest
+++ b/dev-python/cfgv/Manifest
@@ -1 +1,2 @@
DIST cfgv-3.3.0.tar.gz 10393 BLAKE2B d4cf565884aaab6a81716382ba8e3244e36a3381b771f7e206053fa80500205bd3b70b62b611ce4a7f0cb143a763d51eb10b1e29333b7f06e29cb406f9f7f6b8 SHA512 23a238c76635404b150bbc3bb1eafd8eb521171e69bb3f3fee55a0a24c12d2ee152cc7453a41952d2f41a6cb72575dacf4b990dbd443f69026a770c87a1e081f
+DIST cfgv-3.3.1.tar.gz 10395 BLAKE2B 8727a9886334a1fe59aeb0554c4c53139ae7e1f66534102c67f005d66dc1f78cff5e5534468a10b85df645f7e8a2fc72ca6ca2e448d09cb7636d08e8b3843113 SHA512 59c358bab9f2b32a1ac6eb72bba67b76e8368e0cf78c32228a6add200a0205f698aa80d9bd1b1e8701fb699b9599c88a240f76e2c91a602a0c292a67693e6857
diff --git a/dev-python/cfgv/cfgv-3.3.1.ebuild b/dev-python/cfgv/cfgv-3.3.1.ebuild
new file mode 100644
index 000000000000..3d62b21962d0
--- /dev/null
+++ b/dev-python/cfgv/cfgv-3.3.1.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Validate configuration and produce human-readable error messages"
+HOMEPAGE="https://github.com/asottile/cfgv"
+SRC_URI="https://github.com/asottile/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~riscv ~x86"
+
+distutils_enable_tests pytest