summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-12 16:32:12 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-12 17:47:04 -0500
commita69971547996ee7d757dcc0d8ffb7a773928dc09 (patch)
tree69d2818a6ca8b8556aab81d4c881de77f418191e /dev-python/cmd2
parentdev-python/python-monascaclient: 1.14.0 bump (diff)
downloadgentoo-a69971547996ee7d757dcc0d8ffb7a773928dc09.tar.gz
gentoo-a69971547996ee7d757dcc0d8ffb7a773928dc09.tar.bz2
gentoo-a69971547996ee7d757dcc0d8ffb7a773928dc09.zip
dev-python/cmd2: 0.8.9 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/cmd2')
-rw-r--r--dev-python/cmd2/Manifest1
-rw-r--r--dev-python/cmd2/cmd2-0.8.9.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/cmd2/Manifest b/dev-python/cmd2/Manifest
index b0bd21695914..310a9d1e7333 100644
--- a/dev-python/cmd2/Manifest
+++ b/dev-python/cmd2/Manifest
@@ -1,2 +1,3 @@
DIST cmd2-0.7.5.tar.gz 64939 BLAKE2B 57c8d3f4c7c94e8e2627fb5d2cf8c164da72c531808a53118f950ee79fcc2e0f431621ffbd74d275bf508c8646ded761d2d38c2b99570fdadbbaddf095e422a1 SHA512 14376ee283ac1c153ab0194a5dfa168eca36174783322ff72e190ed96b8c315518fef4f3ef09d77633851cb53b32f71fe380042ee3c0ef8ef2cbdfa16dabf704
DIST cmd2-0.7.9.tar.gz 71298 BLAKE2B d1623e2d6a7ac66058b5a43a9688ba850962fa7b5659c3287a9aef9a7deb16338d71a2c07ef15ec72ee5e62aae0ce3cdf2f202d0d423040b734dee059f1d4876 SHA512 39086794ea57cdfdc7388aaa485770f1a76457bf2b2f58cd4703dc0c082f58a8343aa777304e833133040fdab8ef8451d85bc3c19721432514bb380330823abd
+DIST cmd2-0.8.9.tar.gz 112543 BLAKE2B b55edd450abcff863a34252b724919ace9f65b62b8175f28a1bb4fb64692a67723339a887dac45e87f37db71773689cfa213038740a4b3d165bf95f9cdad1d0e SHA512 80c80b67f8a1709156450fa476215a5466cca2853102f6012f1d83867a311d86a68d441dcea9895b62add731b3d00a7c3ecefde939b4f2ccd61d058ef9386a84
diff --git a/dev-python/cmd2/cmd2-0.8.9.ebuild b/dev-python/cmd2/cmd2-0.8.9.ebuild
new file mode 100644
index 000000000000..85d0637de7ee
--- /dev/null
+++ b/dev-python/cmd2/cmd2-0.8.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Extra features for standard library's cmd module"
+HOMEPAGE="https://github.com/python-cmd2/cmd2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# restrict tests because pyperclip is fairly unstable...
+RESTRICT="test"
+
+RDEPEND="
+ >=dev-python/pyparsing-2.0.1[${PYTHON_USEDEP}]
+ dev-python/pyperclip[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/subprocess32[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test -vv || die
+ ${EPYTHON} example/example.py --test example/exampleSession.txt || die
+}