summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-05-15 10:18:25 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-05-15 11:47:02 +0200
commit5a582dd4f7fbe284ba95b68ff3c7406eacd4dd90 (patch)
tree3e33f8b07ad6c83f39271668e92e6866057ee485 /dev-python/cssutils/cssutils-1.0.2.ebuild
parentdev-python/alabaster: Bump to version 0.7.10 (diff)
downloadgentoo-5a582dd4f7fbe284ba95b68ff3c7406eacd4dd90.tar.gz
gentoo-5a582dd4f7fbe284ba95b68ff3c7406eacd4dd90.tar.bz2
gentoo-5a582dd4f7fbe284ba95b68ff3c7406eacd4dd90.zip
dev-python/cssutils: Bump to version 1.0.2
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/cssutils/cssutils-1.0.2.ebuild')
-rw-r--r--dev-python/cssutils/cssutils-1.0.2.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/cssutils/cssutils-1.0.2.ebuild b/dev-python/cssutils/cssutils-1.0.2.ebuild
new file mode 100644
index 000000000000..c07182ec400e
--- /dev/null
+++ b/dev-python/cssutils/cssutils-1.0.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A CSS Cascading Style Sheets library"
+HOMEPAGE="https://pypi.python.org/pypi/cssutils/ https://bitbucket.org/cthedot/cssutils http://cthedot.de/cssutils/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+python_prepare_all() {
+ # Disable test failing with dev-python/pyxml installed.
+ if has_version dev-python/pyxml; then
+ sed -e "s/test_linecol/_&/" \
+ -i src/cssutils/tests/test_errorhandler.py \
+ || die
+ fi
+
+ # requires old pbr, does it really?
+ sed \
+ -e '/tests_require/d' \
+ -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ln -s "${S}/sheets" "${BUILD_DIR}/sheets" || die
+ # esetup.py test
+ # exclude tests that connect to the network
+ set -- nosetests \
+ -e test_parseUrl -e test_handlers -P "${BUILD_DIR}/lib/cssutils/tests"
+ echo "$@"
+ "$@" || die "Testing failed with ${EPYTHON}"
+}