summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-21 15:32:16 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-21 15:35:02 +0200
commit0fe085d7abd16f4ff3ae38ae02c71098904cb845 (patch)
tree0c6da2125ac08e95ca319bccb0289c2e2dba5a94 /dev-python/dask
parentdev-python/django_polymorphic: Bump to 3.0.0 (diff)
downloadgentoo-0fe085d7abd16f4ff3ae38ae02c71098904cb845.tar.gz
gentoo-0fe085d7abd16f4ff3ae38ae02c71098904cb845.tar.bz2
gentoo-0fe085d7abd16f4ff3ae38ae02c71098904cb845.zip
dev-python/dask: Respect MAKEOPTS for parallel tests
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dask')
-rw-r--r--dev-python/dask/dask-2.23.0.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-python/dask/dask-2.23.0.ebuild b/dev-python/dask/dask-2.23.0.ebuild
index b4855c7b7821..1930b91f3406 100644
--- a/dev-python/dask/dask-2.23.0.ebuild
+++ b/dev-python/dask/dask-2.23.0.ebuild
@@ -4,7 +4,7 @@
EAPI=7
PYTHON_COMPAT=( python3_{6..9} )
-inherit distutils-r1
+inherit distutils-r1 multiprocessing
DESCRIPTION="Task scheduling and blocked algorithms for parallel processing"
HOMEPAGE="https://dask.org/"
@@ -48,6 +48,7 @@ src_prepare() {
}
python_test() {
- pytest -vv -m "not network" -n auto ||
+ pytest -vv -m "not network" \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" ||
die "Tests failed with ${EPYTHON}"
}