summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-08-11 11:57:52 +0200
committerMichał Górny <mgorny@gentoo.org>2020-08-11 15:43:18 +0200
commit2cf3a7eb2adbbdb324d0cf1e54b8473faa3f31a5 (patch)
treef8ff107db9a7a028abc335f3b54309f9b95458cd /dev-python/docker-py/docker-py-4.3.0.ebuild
parentdev-python/hypothesis: Bump to 5.24.0 (diff)
downloadgentoo-2cf3a7eb2adbbdb324d0cf1e54b8473faa3f31a5.tar.gz
gentoo-2cf3a7eb2adbbdb324d0cf1e54b8473faa3f31a5.tar.bz2
gentoo-2cf3a7eb2adbbdb324d0cf1e54b8473faa3f31a5.zip
dev-python/docker-py: Bump to 4.3.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/docker-py/docker-py-4.3.0.ebuild')
-rw-r--r--dev-python/docker-py/docker-py-4.3.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/docker-py/docker-py-4.3.0.ebuild b/dev-python/docker-py/docker-py-4.3.0.ebuild
new file mode 100644
index 000000000000..ec7b5cd81787
--- /dev/null
+++ b/dev-python/docker-py/docker-py-4.3.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ !~dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/recommonmark' \
+ '>=dev-python/sphinx-1.4.6'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # localhost has a better chance of being in /etc/hosts
+ sed -e 's:socket[.]gethostname():"localhost":' \
+ -i tests/unit/api_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/unit/ || die "tests failed under ${EPYTHON}"
+}