summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-02 22:43:47 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-02 23:00:01 +0200
commit98a1f60e49ce9d5a85301da41f4e2e5e62c58cd2 (patch)
tree92f5a11c69604217852676ee108865f031f7f261 /dev-python/dogpile-cache
parentdev-python/pillow: Bump to 8.3.2 (diff)
downloadgentoo-98a1f60e49ce9d5a85301da41f4e2e5e62c58cd2.tar.gz
gentoo-98a1f60e49ce9d5a85301da41f4e2e5e62c58cd2.tar.bz2
gentoo-98a1f60e49ce9d5a85301da41f4e2e5e62c58cd2.zip
dev-python/dogpile-cache: Bump to 1.1.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dogpile-cache')
-rw-r--r--dev-python/dogpile-cache/Manifest1
-rw-r--r--dev-python/dogpile-cache/dogpile-cache-1.1.4.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dogpile-cache/Manifest b/dev-python/dogpile-cache/Manifest
index 80cc1b4384a3..c761e7531d39 100644
--- a/dev-python/dogpile-cache/Manifest
+++ b/dev-python/dogpile-cache/Manifest
@@ -1 +1,2 @@
DIST dogpile.cache-1.1.3.tar.gz 387490 BLAKE2B 580be4f524196fb56e651d793045bf2e3419d3c98e65be0ba2cfaaed97f9c9cc08efe67191f77b273e97ffe907e8f5e050a7a36d2d8287522a21e7c4290d1354 SHA512 fd735b0bb9b7eb3bb559c030c15ac547aeb3f4718c64d7edb0f26f0f8a71b9b067434e984460c40cfbca57696d2b9579266f0c9d48bad4cb3c5bbc07030a4fb4
+DIST dogpile.cache-1.1.4.tar.gz 390117 BLAKE2B 88c38473c3f177a42c2e336f7913940cde5f793245ddbb2ce3e7569c0853a1f93138a4987dc7781490132f84beb17c568ec9fc9a955201123842ccdbdfff2fc4 SHA512 d70f0ad1097f7de5bc887cfd0835f02a10bd6096433d39e6fe2fad5ed294f019ee043ced670c08bacb8ad1f6cf32ada36a62149a9b6db6205e72f49fa68bf4c4
diff --git a/dev-python/dogpile-cache/dogpile-cache-1.1.4.ebuild b/dev-python/dogpile-cache/dogpile-cache-1.1.4.ebuild
new file mode 100644
index 000000000000..d6e33ac5f616
--- /dev/null
+++ b/dev-python/dogpile-cache/dogpile-cache-1.1.4.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A locking API for expiring values while a single thread generates a new value."
+HOMEPAGE="https://github.com/sqlalchemy/dogpile.cache"
+SRC_URI="mirror://pypi/${PN:0:1}/dogpile.cache/dogpile.cache-${PV}.tar.gz"
+S="${WORKDIR}/dogpile.cache-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/decorator-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-3.0.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest