summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/drpython
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/drpython')
-rw-r--r--dev-python/drpython/Manifest1
-rw-r--r--dev-python/drpython/drpython-3.11.4.ebuild47
-rw-r--r--dev-python/drpython/files/drpython-165-wxversion.patch12
-rw-r--r--dev-python/drpython/metadata.xml17
4 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/drpython/Manifest b/dev-python/drpython/Manifest
new file mode 100644
index 000000000000..8b128f381605
--- /dev/null
+++ b/dev-python/drpython/Manifest
@@ -0,0 +1 @@
+DIST DrPython_3.11.4.zip 824982 SHA256 37a2e4873fb6accd1145f89518db101458c2f43fbc3ea7cf3e2de446bf353f42 SHA512 13943eb28d7155e99e0ffb57903ddde25c964c908ac848f14041c456bc6aa71bab7cad1101e489c09ba5efb5af35e33895a518021bb607f5047844927bcebf2b WHIRLPOOL 56fd68e4abda8f39bbd86060eb397d4bd9360547e26cbca875f8256cadc19efd5de4bedb6d61f116cf63b3cd5167bf0dec9e21bddbbd0d75fdb6c246350ba483
diff --git a/dev-python/drpython/drpython-3.11.4.ebuild b/dev-python/drpython/drpython-3.11.4.ebuild
new file mode 100644
index 000000000000..aeb0837694d2
--- /dev/null
+++ b/dev-python/drpython/drpython-3.11.4.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+MY_PN="DrPython"
+MY_P="${MY_PN}_${PV}"
+
+DESCRIPTION="A powerful cross-platform IDE for Python"
+HOMEPAGE="http://drpython.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ia64 ppc x86"
+IUSE=""
+
+RDEPEND=">=dev-python/wxpython-2.6"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/${PN}"
+
+PAYTCHES=( "${FILESDIR}/${PN}-165-wxversion.patch" )
+
+python_prepare_all() {
+ sed \
+ -e "/'drpython.pyw', 'drpython.lin'/d" \
+ -e "/scripts=\['postinst.py'\],/d" \
+ -i setup.py || die "sed failed"
+ sed -e "s/arguments)c/arguments)/" -i examples/DrScript/SetTerminalArgs.py || die "sed failed"
+ distutils-r1_python_prepare_all
+}
+
+python_install() {
+ make_wrapper drpython "${PYTHON}" $(python_get_sitedir)/${PN}/drpython.py
+ distutils-r1_python_install
+}
+
+pkg_postinst() {
+ elog "DrPython plugins are available on DrPython homepage:"
+ elog "http://sourceforge.net/projects/drpython/files/DrPython%20Plugins/"
+}
diff --git a/dev-python/drpython/files/drpython-165-wxversion.patch b/dev-python/drpython/files/drpython-165-wxversion.patch
new file mode 100644
index 000000000000..bab247c2110c
--- /dev/null
+++ b/dev-python/drpython/files/drpython-165-wxversion.patch
@@ -0,0 +1,12 @@
+diff -Naur drpython-orig/drpython_wx26.py drpython/drpython_wx26.py
+--- drpython_wx26.py 2007-03-23 19:20:02.000000000 -0600
++++ drpython_wx26.py 2007-12-03 18:36:01.000000000 -0600
+@@ -34,7 +34,7 @@
+
+ ## testfile for older version
+ import wxversion
+-wxversion.select("2.60-msw-ansi")
++wxversion.select("2.6")
+
+ if __name__ == '__main__':
+ import drpython
diff --git a/dev-python/drpython/metadata.xml b/dev-python/drpython/metadata.xml
new file mode 100644
index 000000000000..f0809cae54aa
--- /dev/null
+++ b/dev-python/drpython/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription>
+DrPython is a highly customizable, simple, and clean
+editing environment for developing Python programs. It
+is intended primarily for use in schools, and is a tribute to
+DrScheme.
+</longdescription>
+ <longdescription lang="ja">
+DrPythonはPython言語プログラム用の、柔軟で、簡単で、安定した開発環境です。DrSchemeに触発され、学校での教材となる事が念頭にあります。
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">drpython</remote-id>
+ </upstream>
+</pkgmetadata>