summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-04-07 03:13:57 +0300
committerJoonas Niilola <juippis@gentoo.org>2023-05-02 20:07:18 +0300
commit3dfe40dcb61ad1799cc02f8b7b4e652b54d10f1e (patch)
treea970f94301ed3c7de100a6625b55dec97c4bb2b6 /dev-python/elasticsearch-py
parentapp-emulation/wine-proton: fix 7.0.6 build with mingw64 11.0.0 (diff)
downloadgentoo-3dfe40dcb61ad1799cc02f8b7b4e652b54d10f1e.tar.gz
gentoo-3dfe40dcb61ad1799cc02f8b7b4e652b54d10f1e.tar.bz2
gentoo-3dfe40dcb61ad1799cc02f8b7b4e652b54d10f1e.zip
dev-python/elasticsearch-py: disable ssl in tests
Certificates expired and upstream doesnt run ssl tests eitherway, so better to just disable them as well. Signed-off-by: Alfred Wingate <parona@protonmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/elasticsearch-py')
-rw-r--r--dev-python/elasticsearch-py/elasticsearch-py-8.6.2.ebuild13
1 files changed, 1 insertions, 12 deletions
diff --git a/dev-python/elasticsearch-py/elasticsearch-py-8.6.2.ebuild b/dev-python/elasticsearch-py/elasticsearch-py-8.6.2.ebuild
index 9ac55cbfa46b..f39c589bce66 100644
--- a/dev-python/elasticsearch-py/elasticsearch-py-8.6.2.ebuild
+++ b/dev-python/elasticsearch-py/elasticsearch-py-8.6.2.ebuild
@@ -81,8 +81,6 @@ src_test() {
# So lets add a reasonable limit
export ES_JAVA_OPTS="-Xmx4g"
- cp -r "${S}/.ci/certs" "${ES_DIR}/config" || die
-
cat > "${ES_DIR}/config/elasticsearch.yml" <<-EOF || die
# Run elasticsearch on custom port
http.port: ${es_port}
@@ -95,16 +93,7 @@ src_test() {
xpack.license.self_generated.type: basic
xpack.security.enabled: true
- xpack.security.http.ssl.enabled: true
- xpack.security.http.ssl.verification_mode: certificate
- xpack.security.http.ssl.key: certs/testnode.key
- xpack.security.http.ssl.certificate: certs/testnode.crt
- xpack.security.http.ssl.certificate_authorities: certs/ca.crt
- xpack.security.transport.ssl.enabled: true
- xpack.security.transport.ssl.verification_mode: certificate
- xpack.security.transport.ssl.key: certs/testnode.key
- xpack.security.transport.ssl.certificate: certs/testnode.crt
- xpack.security.transport.ssl.certificate_authorities: certs/ca.crt
+ xpack.security.http.ssl.enabled: false
EOF
# Set password in keystore