summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfred Wingate <parona@protonmail.com>2023-08-10 14:35:35 +0300
committerSam James <sam@gentoo.org>2023-09-01 13:18:31 +0100
commit3f61144a5f0ef39903ba77753d0ad7ab1ae5d34c (patch)
tree7fe520b58dff3efa2422679a848557d54b3f1171 /dev-python/elasticsearch
parentdev-python/peewee: comment for native-extensions on pypy3 (diff)
downloadgentoo-3f61144a5f0ef39903ba77753d0ad7ab1ae5d34c.tar.gz
gentoo-3f61144a5f0ef39903ba77753d0ad7ab1ae5d34c.tar.bz2
gentoo-3f61144a5f0ef39903ba77753d0ad7ab1ae5d34c.zip
dev-python/elasticsearch: add 8.9.0
Signed-off-by: Alfred Wingate <parona@protonmail.com> Closes: https://github.com/gentoo/gentoo/pull/32244 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/elasticsearch')
-rw-r--r--dev-python/elasticsearch/Manifest1
-rw-r--r--dev-python/elasticsearch/elasticsearch-8.9.0.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/elasticsearch/Manifest b/dev-python/elasticsearch/Manifest
index 773adfacaf64..fde8b1059be9 100644
--- a/dev-python/elasticsearch/Manifest
+++ b/dev-python/elasticsearch/Manifest
@@ -1 +1,2 @@
DIST elasticsearch-py-8.8.2.gh.tar.gz 527409 BLAKE2B e7768150e22995b4ae4a5b0898a252c46e90b224e8c4132a7035d726db9367facfe2cd006c0d319454c61c075d180776f567e45791d731bf1fc1d40a78d284a2 SHA512 5e5610425fe3727b817fbeafb411fa3e455a1f08c4992774c95c93c5b0d01880198d39febb18baee7a1da85bd126d9679fb6a2aac4602df8ec49cfff0b5bd3be
+DIST elasticsearch-py-8.9.0.gh.tar.gz 881506 BLAKE2B 7e6813ff5d5f5f90e67f479258506736a07fac45529f3e957a10cec8251a923afaf3ce4a88f34be8c1dccc4d2df95f87e2b97e05c296bf530f169bd6756b0779 SHA512 b8054edd2bb7577601b2dfe423ff5b191d59abcc1e8aaba86af18be3215548b2d540bb398b5ad83955da99c35995c4ba2755c9da3823fab1fffb0e7a01633f32
diff --git a/dev-python/elasticsearch/elasticsearch-8.9.0.ebuild b/dev-python/elasticsearch/elasticsearch-8.9.0.ebuild
new file mode 100644
index 000000000000..9aa78c8ea55f
--- /dev/null
+++ b/dev-python/elasticsearch/elasticsearch-8.9.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+inherit distutils-r1
+
+MY_P="elasticsearch-py-${PV}"
+
+DESCRIPTION="Official Elasticsearch client library for Python"
+HOMEPAGE="
+ https://ela.st/es-python
+ https://github.com/elastic/elasticsearch-py
+ https://pypi.org/project/elasticsearch/
+"
+SRC_URI="https://github.com/elastic/elasticsearch-py/archive/refs/tags/v${PV}.tar.gz -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Apache-2.0"
+SLOT="0/$(ver_cut 1)"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-python/aiohttp-3[${PYTHON_USEDEP}] <dev-python/aiohttp-4[${PYTHON_USEDEP}]
+ >=dev-python/elastic-transport-8[${PYTHON_USEDEP}] <dev-python/elastic-transport-9[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4[${PYTHON_USEDEP}] <dev-python/requests-3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mapbox-vector-tile[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pandas[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/pyyaml-5.4[${PYTHON_USEDEP}]
+ dev-python/unasync[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # REST api tests are a black hole for effort. It downloads the tests so its an ever moving target
+ # It also requires effort to blacklist tests for apis which are license restricted.
+ "test_elasticsearch/test_server/test_rest_api_spec.py"
+ # Counting deprecation warnings from python is bound to fail even if all are fixed in this package
+ # Not worth it
+ "test_elasticsearch/test_client/test_deprecated_options.py"
+ # Running daemon for tests is finicky and upstream CI fails at it as well
+ "test_elasticsearch/test_server/"
+ "test_elasticsearch/test_async/test_server/"
+)
+
+distutils_enable_sphinx docs/sphinx dev-python/sphinx-rtd-theme
+distutils_enable_tests pytest
+
+src_prepare() {
+ # Replace added pytest options with setting asyncio_mode to auto.
+ # Test suite hasnt set asyncio parameters so its needed here.
+ sed -i '/[tool:pytest]/,/^$/ { s/addopts.*/asyncio_mode = auto/ }' setup.cfg || die
+
+ default
+}