summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-04-28 20:51:56 +0200
committerMichał Górny <mgorny@gentoo.org>2022-04-28 20:51:56 +0200
commit75116429352d84634a828a2a27329ff2ba5c25f1 (patch)
treef2a5b281e78c062d94c8be9abb708e319f829932 /dev-python/elementpath
parentdev-python/flask-compress: Bump to 1.12 (diff)
downloadgentoo-75116429352d84634a828a2a27329ff2ba5c25f1.tar.gz
gentoo-75116429352d84634a828a2a27329ff2ba5c25f1.tar.bz2
gentoo-75116429352d84634a828a2a27329ff2ba5c25f1.zip
dev-python/elementpath: Bump to 2.5.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/elementpath')
-rw-r--r--dev-python/elementpath/Manifest1
-rw-r--r--dev-python/elementpath/elementpath-2.5.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/elementpath/Manifest b/dev-python/elementpath/Manifest
index e99735f26d80..9a4ae5989e2b 100644
--- a/dev-python/elementpath/Manifest
+++ b/dev-python/elementpath/Manifest
@@ -1 +1,2 @@
DIST elementpath-2.5.0.gh.tar.gz 263680 BLAKE2B 50ecea0766ddad4239b9283b223e945ae12fabf51bc246bb672517d04912b07cc2d46c1f04ff74f7f6da44d7dc422cde0c38a1f25a1f61068390dbfcc5ad58c4 SHA512 bbc6ce6a6a3eb3312d53be6040b8f4676f460e76de9b476410a3170734410b7a3d61c53081633d39089def05c74446d26abe093f02b9686a595cdb6e10440047
+DIST elementpath-2.5.1.gh.tar.gz 263727 BLAKE2B adfc3727c8afe691ba09e143249779ca3f0cee2fd743963b013d790215b30650eecbe2c924a026c07f9018a23710a0ade6e83567103d8eeffd85a71d398b7c77 SHA512 35c272a9f3dc2ddb1ab6b1aaa67588c1e3fcc5765a2edfd4dae47346b7b45f209b38a501a24f0c37b5ca0d933928c13b8608f33a2aadc57e1e4eeb928a491ab8
diff --git a/dev-python/elementpath/elementpath-2.5.1.ebuild b/dev-python/elementpath/elementpath-2.5.1.ebuild
new file mode 100644
index 000000000000..d2b8df609526
--- /dev/null
+++ b/dev-python/elementpath/elementpath-2.5.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="XPath 1.0/2.0 parsers and selectors for ElementTree and lxml"
+HOMEPAGE="
+ https://github.com/sissaschool/elementpath/
+ https://pypi.org/project/elementpath/
+"
+SRC_URI="
+ https://github.com/sissaschool/elementpath/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # fails for some reason, more fit for upstream testing anyway
+ rm tests/test_typing.py || die
+ distutils-r1_src_prepare
+}