summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/enaml
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/enaml')
-rw-r--r--dev-python/enaml/Manifest2
-rw-r--r--dev-python/enaml/enaml-0.6.8-r1.ebuild57
-rw-r--r--dev-python/enaml/enaml-0.9.8.ebuild60
-rw-r--r--dev-python/enaml/metadata.xml14
4 files changed, 133 insertions, 0 deletions
diff --git a/dev-python/enaml/Manifest b/dev-python/enaml/Manifest
new file mode 100644
index 000000000000..480e0f8de1db
--- /dev/null
+++ b/dev-python/enaml/Manifest
@@ -0,0 +1,2 @@
+DIST enaml-0.6.8.tar.gz 4550240 SHA256 e0f3f5775bfd471b9ca748a547cde1b9b129e0e43f1b6adbcde6fcdcbbb18a9f SHA512 8942ae1f44aee97acc1813e684534ce982fcc48090a9295e95c56a8bbc2063a94c2561ff0752cb5ff9f1f08b7ebaa44bb3b16ea78cbb0821efdcb56f3cf72446 WHIRLPOOL d1d912cb62f3b33c848d89ed9e8f2bb4e03d5f9732903f7bd8180ed58cbf80993600b629e7753909c4d599db74d1d369a59b5dc568e2cb46773e579914e213bc
+DIST enaml-0.9.8.tar.gz 1455642 SHA256 c646f12dc7928555f2f24a10706c0d668b11a5e63e4b878dcb267247bf22a1d5 SHA512 e9b88d1fbb9e82564d3a865f74685b1b1f8b8918e29dd4d7ce7d6b4b2e6d386c6388e99f9bf0adb02fb9277a57519f8502a33bd6e0548fd1a4d52d0a4b33cf02 WHIRLPOOL f9c6874f7fec569acdbf74c5cdd24c6189506980ca65028c3ea53ed076338a5edea6b19d018d19b8662385b058d9c96c7e36239a1f86d8c1cdcada559f49bfd8
diff --git a/dev-python/enaml/enaml-0.6.8-r1.ebuild b/dev-python/enaml/enaml-0.6.8-r1.ebuild
new file mode 100644
index 000000000000..da0b0835d020
--- /dev/null
+++ b/dev-python/enaml/enaml-0.6.8-r1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Enthought Tool Suite: framework for writing declarative interfaces"
+HOMEPAGE="http://code.enthought.com/projects/enaml/ http://pypi.python.org/pypi/enaml"
+SRC_URI="http://www.enthought.com/repo/ets/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples test"
+
+RDEPEND="
+ dev-python/casuarius[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/traits[${PYTHON_USEDEP}]
+ || (
+ dev-python/wxpython:*[${PYTHON_USEDEP}] \
+ dev-python/PyQt4[${PYTHON_USEDEP}] \
+ dev-python/pyside[${PYTHON_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # crash doc and gone upstream (> 0.2.0)
+ sed -i -e '/enthought.debug.api/d' enamldoc/sphinx_ext.py || die
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyside
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/enaml/enaml-0.9.8.ebuild b/dev-python/enaml/enaml-0.9.8.ebuild
new file mode 100644
index 000000000000..8caf0e45412c
--- /dev/null
+++ b/dev-python/enaml/enaml-0.9.8.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 virtualx flag-o-matic
+
+DESCRIPTION="Enthought Tool Suite: framework for writing declarative interfaces"
+HOMEPAGE="http://code.enthought.com/projects/enaml/ http://pypi.python.org/pypi/enaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/atom-0.3.8[${PYTHON_USEDEP}]
+ >=dev-python/kiwisolver-0.1.2[${PYTHON_USEDEP}]
+ >=dev-python/ply-3.4[${PYTHON_USEDEP}]
+ || (
+ dev-python/wxpython:*[${PYTHON_USEDEP}] \
+ dev-python/PyQt4[${PYTHON_USEDEP}] \
+ dev-python/pyside[${PYTHON_USEDEP}] )"
+
+DEPEND="${RDEPEND}
+ test? ( dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/wxpython[${PYTHON_USEDEP}]
+ dev-python/pyside[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# The testsuite antagonises gentoo conventions far beyond what can currently be dealt with
+# It also passes all once run
+RESTRICT="test"
+
+# Doc build now fails, missing required folder, use doc removed for now
+# https://github.com/nucleic/enaml/issues/170
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export ETS_TOOLKIT=qt4
+ export QT_API=pyside
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+# use doc && local HTML_DOCS=( docs/build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/enaml/metadata.xml b/dev-python/enaml/metadata.xml
new file mode 100644
index 000000000000..f19f96398f51
--- /dev/null
+++ b/dev-python/enaml/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <longdescription lang="en">
+ Enaml is a framework for writing declarative user interfaces in
+ Python. It provides a Yaml-ish/Pythonic syntax language for
+ declaring a ui that binds and reacts to changes in the user's
+ models. Code can freely call back and forth between Python and Enaml.
+</longdescription>
+ <upstream>
+ <remote-id type="pypi">enaml</remote-id>
+ </upstream>
+</pkgmetadata>