summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-02 05:53:15 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-02 05:53:15 +0100
commitc01fc9e5b1b5682917187e04ee445c1f7d68b79d (patch)
tree13210238f37620bb19d8b6ea0e6f8e8ae54ece82 /dev-python/eradicate/eradicate-2.2.0.ebuild
parentdev-python/google-api-python-client: Bump to 2.80.0 (diff)
downloadgentoo-c01fc9e5b1b5682917187e04ee445c1f7d68b79d.tar.gz
gentoo-c01fc9e5b1b5682917187e04ee445c1f7d68b79d.tar.bz2
gentoo-c01fc9e5b1b5682917187e04ee445c1f7d68b79d.zip
dev-python/eradicate: Bump to 2.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/eradicate/eradicate-2.2.0.ebuild')
-rw-r--r--dev-python/eradicate/eradicate-2.2.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/eradicate/eradicate-2.2.0.ebuild b/dev-python/eradicate/eradicate-2.2.0.ebuild
new file mode 100644
index 000000000000..d77ad1099711
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="
+ https://github.com/myint/eradicate/
+ https://pypi.org/project/eradicate/
+"
+SRC_URI="
+ https://github.com/myint/eradicate/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest