summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-10 08:25:50 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-10 08:54:15 +0200
commit9a95ea939dcf273d1cdf521df92aadee6f7fefd4 (patch)
treefd9d223920b5aceda75b58a086a0dc615181636d /dev-python/execnet
parentdev-lang/python-exec: Remove old (diff)
downloadgentoo-9a95ea939dcf273d1cdf521df92aadee6f7fefd4.tar.gz
gentoo-9a95ea939dcf273d1cdf521df92aadee6f7fefd4.tar.bz2
gentoo-9a95ea939dcf273d1cdf521df92aadee6f7fefd4.zip
dev-python/execnet: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/execnet')
-rw-r--r--dev-python/execnet/execnet-1.9.0.ebuild46
1 files changed, 0 insertions, 46 deletions
diff --git a/dev-python/execnet/execnet-1.9.0.ebuild b/dev-python/execnet/execnet-1.9.0.ebuild
deleted file mode 100644
index 2b0686417857..000000000000
--- a/dev-python/execnet/execnet-1.9.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Rapid multi-Python deployment"
-HOMEPAGE="https://codespeak.net/execnet/
- https://pypi.org/project/execnet/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-BDEPEND="
- dev-python/setuptools_scm[${PYTHON_USEDEP}]"
-
-distutils_enable_sphinx doc
-distutils_enable_tests pytest
-
-python_prepare_all() {
- sed -i -r 's:(,[[:space:]]*|)"eventlet":: ; s:(,[[:space:]]*|)"gevent"(,|)::' \
- testing/conftest.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- local deselect=(
- # needs python2.7 with apipkg?
- 'testing/test_termination.py::test_close_initiating_remote_no_error[python2.7]'
- # tries to run python2
- testing/test_channel.py::TestStringCoerce::test_3to2
- testing/test_gateway.py::TestStringCoerce::test_3to2
- # does not like Gentoo defaults
- testing/test_gateway.py::TestPopenGateway::test_dont_write_bytecode
- # almost all tests call py2, not worth filtering for the rest
- testing/test_serializer.py
- )
-
- epytest ${deselect[@]/#/--deselect }
-}