summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-06-22 17:43:23 +0200
committerMichał Górny <mgorny@gentoo.org>2021-06-22 18:29:41 +0200
commitf8e4237cf642c9f82373e5447d9ec38ccc434a51 (patch)
treec2f21c5accabe846ea5c3bb2dc3e28df41660236 /dev-python/feedparser/feedparser-6.0.8.ebuild
parentdev-python/h5py: Bump to 3.3.0 (diff)
downloadgentoo-f8e4237cf642c9f82373e5447d9ec38ccc434a51.tar.gz
gentoo-f8e4237cf642c9f82373e5447d9ec38ccc434a51.tar.bz2
gentoo-f8e4237cf642c9f82373e5447d9ec38ccc434a51.zip
dev-python/feedparser: Bump to 6.0.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/feedparser/feedparser-6.0.8.ebuild')
-rw-r--r--dev-python/feedparser/feedparser-6.0.8.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/feedparser/feedparser-6.0.8.ebuild b/dev-python/feedparser/feedparser-6.0.8.ebuild
new file mode 100644
index 000000000000..20498a98346b
--- /dev/null
+++ b/dev-python/feedparser/feedparser-6.0.8.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..9} pypy3 )
+
+inherit distutils-r1
+
+MY_PV=${PV/_beta/b}
+MY_P=${PN}-${MY_PV}
+DESCRIPTION="Parse RSS and Atom feeds in Python"
+HOMEPAGE="https://github.com/kurtmckee/feedparser
+ https://pypi.org/project/feedparser/"
+SRC_URI="
+ https://github.com/kurtmckee/feedparser/archive/${MY_PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+
+RDEPEND="dev-python/sgmllib3k[${PYTHON_USEDEP}]"
+
+distutils_enable_tests unittest
+
+src_prepare() {
+ # broken
+ rm \
+ tests/illformed/chardet/big5.xml \
+ tests/illformed/undeclared_namespace.xml || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${EPYTHON}" tests/runtests.py || die
+}