summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-23 11:33:15 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-23 11:33:15 +0200
commit4a728b7e6beccd190461eb915d212712cdc90bda (patch)
tree871aabb2f896a5d466859b8c961b198d139cec15 /dev-python/flake8/flake8-3.9.2-r1.ebuild
parentdev-python/pydocstyle: Use PEP517 build (diff)
downloadgentoo-4a728b7e6beccd190461eb915d212712cdc90bda.tar.gz
gentoo-4a728b7e6beccd190461eb915d212712cdc90bda.tar.bz2
gentoo-4a728b7e6beccd190461eb915d212712cdc90bda.zip
dev-python/flake8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8/flake8-3.9.2-r1.ebuild')
-rw-r--r--dev-python/flake8/flake8-3.9.2-r1.ebuild36
1 files changed, 0 insertions, 36 deletions
diff --git a/dev-python/flake8/flake8-3.9.2-r1.ebuild b/dev-python/flake8/flake8-3.9.2-r1.ebuild
deleted file mode 100644
index ba315d7ed262..000000000000
--- a/dev-python/flake8/flake8-3.9.2-r1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
- >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
-"
-PDEPEND="
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- test? (
- ${PDEPEND}
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
-distutils_enable_tests --install pytest